Repositories all Offline

Use this forum to ask questions after your subscription maintenance expires or before you buy. Need information on licensing or pricing? Questions about a trial version? This is the right place for you. No scripting questions, please.
Forum rules
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
Posts: 7
Last visit: Tue Nov 10, 2020 8:13 am

Repositories all Offline

Post by pmascari »

Product, version and build: VersionRecall 2015, v. 1.0.123
32 or 64 bit version of product: 64bit
Operating system: Windows 2008 Server VM
32 or 64 bit OS: 64bit

I am running VersionRecall as a trial and haven't had any luck getting the auto versioning to run. The logs show every repository as being offline. I read in some other posts that you think this is a permissions issue. So, I've set up my repositories on an NAS with Read/Write permissions given to Everybody. I've tried running the service as: System, local machine admin, and domain admin.

The initial setup and folder submission seems to go fine. I have one copy of all my scripts. However, if I manually submit the folder the Output window says: Submitting files to repository.... and then it just sits there. Nothing gets done. It seems to time out after a while. All timed updates just show as Repository Offline in the logs.

I tried deleting all repositories and then setting up just a few as new. Same behavior.


Site Admin
Posts: 1098
Last visit: Tue Jun 06, 2017 9:15 am

Re: Repositories all Offline

Post by DevinL »

I'm currently looking into this and will get back as soon as I have some more information.
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 7719
Last visit: Sat Jul 31, 2021 12:28 pm
Answers: 4
Been upvoted: 10 times

Re: Repositories all Offline

Post by Alexander Riedel »

It doesn't say here how you reach your NAS. The service runs by default under the system account. If your NAS is a mapped drive or needs a login to be accessible, then the system account may not be able to see it or access it.
Maybe it would be best if you tell us what the exact location of your local folder is and what the exact location of the repository is. Maybe that will allow us to see what the reason is.
Alexander Riedel
SAPIEN Technologies, Inc.