Invalid Drive O:\ when trying to install

Support for all customers who have purchased a PrimalScript product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
vgerretz
Posts: 3
Joined: Fri Sep 09, 2011 7:04 am

Invalid Drive O:\ when trying to install

Post by vgerretz » Fri Sep 09, 2011 7:04 am

I have been trying to install PrimalScript2011 Build 150 on to a Windows 7 x64 workstation. When I run the install, I get the following error:
Image
The workstation is connected to the company's network and Drive O: was here when the initial install occurred.

User avatar
Alexander Riedel
Posts: 6818
Joined: Tue May 29, 2007 4:43 pm

Invalid Drive O:\ when trying to install

Post by Alexander Riedel » Fri Sep 09, 2011 7:31 am

So I take it that the O: drive no longer exists?

In order to install a new service build PrimalScript does a quick uninstall of the previous build while preserving all your data and settings. Then it installs the new build.

If the MSI of the currently installed build is no longer accessible you should try a manual uninstall or remove the previous version's Windows Installer references from the registry.
If a manual uninstall is not working and you need assistance with the latter please let us know.
Then install the new build by running the setup executable.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
vgerretz
Posts: 3
Joined: Fri Sep 09, 2011 7:04 am

Invalid Drive O:\ when trying to install

Post by vgerretz » Fri Sep 09, 2011 7:58 am

I am installing on a new machine, PrimalScript2011 Build 150 was never installed on it and Drive O: is mapped. PS2011 is not listed in Programs that are installed. The install process does not get that far.

The "My Documents" was moved from the local drive to the network drive. Would this impact the install on a new machine?

User avatar
vgerretz
Posts: 3
Joined: Fri Sep 09, 2011 7:04 am

Invalid Drive O:\ when trying to install

Post by vgerretz » Fri Sep 09, 2011 8:10 am

Got the following entry in Application Event Viewer.

Product: PrimalScript 2011 -- Error 1327. Invalid Drive: O:

User avatar
Alexander Riedel
Posts: 6818
Joined: Tue May 29, 2007 4:43 pm

Invalid Drive O:\ when trying to install

Post by Alexander Riedel » Fri Sep 09, 2011 8:25 am

There can be a couple of places where redirection can be a problem:

The installer tries to create a folder
[My Documents]SAPIEN Scripts.

If the installer has no access permissions this is one of the potential error messages.

The installer also requires elevation. I can't tell if you running under a non-admin user and enter the credentials of an admin account when prompted for elevation. If that is the case, can it be that the account you provide does not have the O: drive mapped?
Alexander Riedel
SAPIEN Technologies, Inc.