No modules pwsh 7.1

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
lanta01
Posts: 2
Last visit: Tue Nov 24, 2020 11:33 pm
Has voted: 1 time

No modules pwsh 7.1

Post by lanta01 »

Versions:
Operating System: Windows 10 Pro 1909
OS build: 18363.1198
32 or 64 bit OS: 64 bit
Screen Resolutions: DISPLAY1: 1920 x 1080 with scale factor 100%, DISPLAY2: 1920 x 1080 with scale factor 100%
PowerShell Core: 7.1.0.0
PowerShell Core (x86): 7.1.0.0
.NET Core Framework: 3.1.3
.NET Core Framework (x86): No .NET Core Framework (x86) version detected
.NET Core Desktop: 3.1.3
.NET Core Desktop (x86): No .NET Core Desktop (x86) version detected
PowerShell cache:
PowerShell 5: 32 Bit, 64 Bit
SAPIEN Software:
Document Explorer 2019: 3.1.90.0,
PowerShell Studio 2020: 5.7.182.0,
SAPIEN Updates: 1.1.37.0,
ScriptMerge 2020: 1.4.83.0
.NET Framework runtime: 4.8 or later
Visual Studio runtime: 14.0: v14.24.28127.04

When i select
2020-11-24_11-07-21.png
2020-11-24_11-07-21.png (6.02 KiB) Viewed 1455 times
The modules are missing and intellisense does not work.
2020-11-24_11-09-32.png
2020-11-24_11-09-32.png (7.49 KiB) Viewed 1455 times

Also when i start Cache Builder i get this error :
2020-11-24_11-11-04.png
2020-11-24_11-11-04.png (4.07 KiB) Viewed 1455 times
Can someone help?
by Alexander Riedel » Tue Nov 24, 2020 2:29 am
PowerShell 7.1 is not supported yet. It uses the new .NET 5.0. Basically it means we need to rebuild, recompile and retest everything, which takes time.
It will be supported in an upcoming service release.
Go to full post

User avatar
Alexander Riedel
Posts: 7670
Last visit: Sun May 02, 2021 12:05 pm
Answers: 3
Been upvoted: 9 times

Re: No modules pwsh 7.1

Post by Alexander Riedel »

PowerShell 7.1 is not supported yet. It uses the new .NET 5.0. Basically it means we need to rebuild, recompile and retest everything, which takes time.
It will be supported in an upcoming service release.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
lanta01
Posts: 2
Last visit: Tue Nov 24, 2020 11:33 pm
Has voted: 1 time

Re: No modules pwsh 7.1

Post by lanta01 »

Alexander Riedel wrote:
Tue Nov 24, 2020 2:29 am
PowerShell 7.1 is not supported yet. It uses the new .NET 5.0. Basically it means we need to rebuild, recompile and retest everything, which takes time.
It will be supported in an upcoming service release.
Thanks Alexander!
Deinstalled 7.1, installed 7.0 and it works.