Using Module and Edit Parameters conflict

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
michelverbeek
Posts: 2
Meble kuchenne na zamówienie - na wymiar - Wrocław
Joined: Fri Dec 04, 2015 10:11 am

Using Module and Edit Parameters conflict

Post by michelverbeek »

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio 2020 v5.7.179
32 or 64 bit version of product: 64 bit
Operating system: Windows 10 (1909)
32 or 64 bit OS: 64 bit

*** Please add details and screenshots as needed below. ***

Hi,

I make use of the 'using' statement to import classes from modules. As is documented the using statement must be the first statement that is not comment.

When I put the the using statement after the first block comment that contains Help Comment (to be used with Get-Help) this works fine. But when I then edit the script parameters the using statement is removed by the parameter editor of PSS.

This can be solved by putting the line with the using statement before the Help Comment block, but then get-help is not able to make fully use of the capabilities it has: it shows only a synopsis, but the -full, -detailed, etc switches do not work.

I can work around this for now, but this means I have to edit my code with Notepad to prepare it for production. Unless I missed something I presume this is a bug, not a feature ;)

TIA,

Michel Verbeek
Wageningen
Netherlands.



DO NOT POST LICENSES, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM
Michel Verbeek
Wageningen University

User avatar
Olga_B
Site Admin
Posts: 147
Joined: Mon May 15, 2017 9:06 am

Re: Using Module and Edit Parameters conflict

Post by Olga_B »

The issue has been sent to the proper place for evaluation and correction. When a fix is issued with a service build, it will be listed in the change log.