Script Driver error when running selection

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
jw8080
Posts: 10
Joined: Tue Aug 07, 2018 10:51 am

Re: Script Driver error when running selection

Post by jw8080 » Tue Aug 07, 2018 1:38 pm

So using: https://docs.microsoft.com/en-us/sysint ... ds/procmon

I filtered out all activity by scriptdriver64.exe so going to attach that also. Not sure if that will help during the debugging process but it may be worth a look.

So it could be just a false positive then? The question then is how to get it to not display an error then.

Thanks!

User avatar
davidc
Posts: 5526
Joined: Thu Aug 18, 2011 4:56 am

Re: Script Driver error when running selection

Post by davidc » Tue Aug 07, 2018 1:48 pm

Could be, but we are not sure yet. If that is the case, we would need to modify the ScriptDriver to ignore the false error. Right now, we are trying to recreate it on our end.
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5526
Joined: Thu Aug 18, 2011 4:56 am

Re: Script Driver error when running selection

Post by davidc » Tue Aug 07, 2018 1:51 pm

Do you have another machine you can test to see if you get the same error?
David
SAPIEN Technologies, Inc.

jw8080
Posts: 10
Joined: Tue Aug 07, 2018 10:51 am

Re: Script Driver error when running selection

Post by jw8080 » Tue Aug 07, 2018 1:53 pm

We bought 2 licenses and the other person using it on his Windows 10 VM isn't having the same issue, so it may be something specific to my pc.

jw8080
Posts: 10
Joined: Tue Aug 07, 2018 10:51 am

Re: Script Driver error when running selection

Post by jw8080 » Wed Aug 08, 2018 1:17 pm

Any luck re-creating the issue? Is it odd as I'm really not doing much at all during the script? so not sure what else I really have going to cause in issue.

Thanks!

User avatar
davidc
Posts: 5526
Joined: Thu Aug 18, 2011 4:56 am

Re: Script Driver error when running selection

Post by davidc » Wed Aug 08, 2018 2:37 pm

No luck recreating the issue yet and I don't think the contents of the script is involved.

Do you have a VM on your machine you could test on? I'm curious to see if that would also be affected.
David
SAPIEN Technologies, Inc.

jw8080
Posts: 10
Joined: Tue Aug 07, 2018 10:51 am

Re: Script Driver error when running selection

Post by jw8080 » Thu Aug 09, 2018 8:32 am

I don't on my local machine but do have a Windows 2012 VM on VMware environment. However, that would be a totally different install that probably wouldn't have the same issues as Windows 10 may have.

jw8080
Posts: 10
Joined: Tue Aug 07, 2018 10:51 am

Re: Script Driver error when running selection

Post by jw8080 » Fri Aug 10, 2018 12:03 pm

Hello?

User avatar
davidc
Posts: 5526
Joined: Thu Aug 18, 2011 4:56 am

Re: Script Driver error when running selection

Post by davidc » Tue Aug 14, 2018 8:09 am

We released a new service build (v5.5.154) with the changes to the ScriptDriver mentioned previously. Please try this build and let us know if you still get any errors.
David
SAPIEN Technologies, Inc.