Sapien updates wants me to "update" to an out-of-date version of PrimalScript

Support for all customers who have purchased a PrimalScript product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
whiggs2
Posts: 28
Joined: Sat Sep 23, 2017 11:59 pm

Sapien updates wants me to "update" to an out-of-date version of PrimalScript

Post by whiggs2 » Sun Jul 01, 2018 8:56 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PrimalScript Version 7.4.114
32 or 64 bit version of product: 64 bit
Operating system: Image
32 or 64 bit OS: 64 bit

This issue has occurred on both devices that I have PrimalScript installed on. I opened Sapien Update to download and install available updates for my sapien applications, including PrimalScript. During the updates (specifically, I believe it was for VersionRecall), the Windows explorer process was terminated. I figured that this was as expected, however, not only did windows explorer not restart after the installation was finished, but when I manually relaunched it, explorer froze up as it was loading and numerous other running applications froze up as well, forcing me to restart my machine using the task manager to run "shutdown /r /f /t 0". When my devices restarted, I once again ran sapien update to verify that there were no more updates that needed to be installed. However, Sapien updates seems to have a bug, as it is reporting that that the version of PrimalScript that I have installed is 7.4.1144, and that I need to "update" to version 7.4.1143, which, of course, doesn't make a lot of sense (please see below picture):
Image

User avatar
Alexander Riedel
Posts: 6685
Joined: Tue May 29, 2007 4:43 pm

Re: Sapien updates wants me to "update" to an out-of-date version of PrimalScript

Post by Alexander Riedel » Sun Jul 01, 2018 9:50 am

Thanks for letting us now. It was a typo in one of the file on our server. I have corrected that.
As for VersionRecall, the problems stems from a Windows Explorer plugin and something that lately prevents Windows Explorer from restarting correctly.
we are in the process of eliminating this plugin to avoid such problems altogether.
Alexander Riedel
SAPIEN Technologies, Inc.