Can't set PrimalXML as Default Program... again.

Support for all customers who have purchased a PrimalXML product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
sblaylock
Posts: 36
Joined: Tue May 31, 2011 5:00 am

Can't set PrimalXML as Default Program... again.

Post by sblaylock » Mon Mar 19, 2018 9:13 am

PrimalXML 2018 Version 4.4.475 - 64bit, Windows 7 Pro 64bit.

This is a repeat of my last post on this when upgrading from PrimalXML 2016 to PrimalXML 2017...

After a recent update from PrimalXML 2016 to PrimalXML 2017, my PrimalXML was no longer the default XML program. I went through the usual Open with... Choose default program. PrimalXML wasn't listed in Recommended Programs... or Other Programs... I click Browse..., navigate to PrimalXML.exe and click Open. Nothing happens in the Open with... dialog. I click OK and get "The file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel." I go through the Default Programs in control panel process and get the same result.

PrimalXML works fine on my system, except for the annoying intermittent scrolling issue that's been around for several years, I just can't seem to make it the default xml program. I've associated xml to another xml editor and then tried to associate it to PrimalXML, but still no joy.


This time I have the reg entries that are still hanging around for PrimalXML 2017. To fix the issue last time I did a find/replace in the registry "PrimalXML 2016" to "PrimalXML 2017". I'm assuming that will fix this issue again, but wanted to list them so you can research the problem:

HKEY_CLASSES_ROOT\Applications\PrimalXML.exe\shell\open\command
HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache
HKEY_CLASSES_ROOT\wsdl_auto_file\shell\open\command
HKEY_CLASSES_ROOT\xsd_auto_file\shell\open\command
HKEY_CURRENT_USER\Software\Classes\Applications\PrimalXML.exe\shell\open\command
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache
HKEY_CURRENT_USER\Software\Classes\wsdl_auto_file\shell\open\command
HKEY_CURRENT_USER\Software\Classes\xsd_auto_file\shell\open\command
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Wordpad\Recent File List
HKEY_CURRENT_USER\Software\SAPIEN Technologies, Inc.\PrimalXML 2018\BCGWorkspace\BCGControlBarVersion\SOFTWARE\SAPIEN Technologies, Inc.\PrimalXML 2017
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429\Software\Classes\Applications\PrimalXML.exe\shell\open\command
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429\Software\Classes\wsdl_auto_file\shell\open\command
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429\Software\Classes\xsd_auto_file\shell\open\command
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429\Software\Microsoft\Windows\CurrentVersion\Applets\Wordpad\Recent File List
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429\Software\SAPIEN Technologies, Inc.\PrimalXML 2018\BCGWorkspace\BCGControlBarVersion\SOFTWARE\SAPIEN Technologies, Inc.\PrimalXML 2017
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429_Classes\Applications\PrimalXML.exe\shell\open\command
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429_Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429_Classes\wsdl_auto_file\shell\open\command
HKEY_USERS\S-1-5-21-2129867641-1448237841-168566570-545429_Classes\xsd_auto_file\shell\open\command

Let me know if you need, hopefully not all of, the actual entries and not just the locations.

Scott.

User avatar
davidc
Posts: 5190
Joined: Thu Aug 18, 2011 4:56 am

Re: Can't set PrimalXML as Default Program... again.

Post by davidc » Tue Mar 20, 2018 9:35 am

PrimalXML's installer does not create any file associations. We leave it up to the user to make any associations in regards to XML.

PrimalXML does add an entry in the file context menu->"Edit with PrimalXML" command on perceived Text files (which includes XML files). We will look into having PrimalXML appear in the "Open with..." list.
David
SAPIEN Technologies, Inc.

User avatar
sblaylock
Posts: 36
Joined: Tue May 31, 2011 5:00 am

Re: Can't set PrimalXML as Default Program... again.

Post by sblaylock » Tue Mar 20, 2018 9:46 am

Something changed a couple of years ago as I was always able to associate PrimalXML with xml files in the Open with... Choose default program.

Same thing this time as last. Once I did the find/replace on PrimalXML 2017 to PrimalXML 2018 I was able to select it as the default for xml files. The "Edit with PrimalXML" was always there and worked correctly.

Scott.

User avatar
Olga_B
Site Admin
Posts: 44
Joined: Mon May 15, 2017 9:06 am

Re: Can't set PrimalXML as Default Program... again.

Post by Olga_B » Tue Mar 20, 2018 1:52 pm

You still can associate .xml files with PrimalXML without changing regkeys.
1. Right click on file, and select Open with/Choose another app
2. Note that PrimalXML will be not listed in the application list
3. Check 'Always use this...' option
4. Scroll down to select 'More apps' option, and then scroll down to select
Look for another app on this PC
5. In Open with... dialog navigate to the PrimalXML installer directory:
C:\Program Files\SAPIEN Technologies, Inc\PrimalXML 2018
6. Select PrimalXML.exe

User avatar
sblaylock
Posts: 36
Joined: Tue May 31, 2011 5:00 am

Re: Can't set PrimalXML as Default Program... again.

Post by sblaylock » Tue Mar 20, 2018 2:14 pm

Thanks, but if you read my original post you'll see when I do this I get...

Nothing happens in the Open with... dialog. I click OK and get "The file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel."

PrimalXML was associated with xml files and this happens after a "major" update - 2016 to 2017, 2017 to 2018, where the directory is changed. This is when it breaks the association and I'm unable to set it as the default program. The only way to fix it is to walk the registry and change the old references. Last year was 2016 to 2017, this year - 2017 to 2018. Once that's done, it works fine.

The steps you posted are not 100% the same, but that's probably because I'm on Windows 7.

Scott.