Git not working

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
sleddi
Posts: 3
Joined: Mon Sep 02, 2019 3:18 am

Git not working

Post by sleddi » Wed Sep 11, 2019 3:45 am

Hi guys!

Product, version and build:
64 bit version of product: Powershell Studio 2019 5.6.167
Operating system:
64 bit OS: Windows 10 1903
Git Version:
2.23.0 64 bit

I'm still trying to get git working.
If i try to clone a repos i get the message: Unhandled Exception: The path has an invalid character
I never typed in a path!

Error log:
[2019.09.11 - 12:35:01] Unhandled Exception:
Der Pfad hat ein ungültiges Format.
bei System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
bei System.IO.Path.InternalGetDirectoryName(String path)
bei ...ctor( , , String )
bei €..( , , String )
bei €..( , , String )
bei PowerShellStudio.MainFormDX.(Object , ItemClickEventArgs )
bei DevExpress.XtraBars.BarItem.OnClick(BarItemLink link)
bei DevExpress.XtraBars.BarButtonItem.OnClick(BarItemLink link)
bei DevExpress.XtraBars.BarItemLink.OnLinkClick()
bei DevExpress.XtraBars.BarButtonItemLink.OnLinkAction(BarLinkAction action, Object actionArgs)
bei DevExpress.XtraBars.ViewInfo.BarSelectionInfo.ClickLink(BarItemLink link)
bei DevExpress.XtraBars.ViewInfo.BarSelectionInfo.UnPressLink(BarItemLink link)
bei DevExpress.XtraBars.Ribbon.Handler.BaseRibbonHandler.OnUnPressItem(DXMouseEventArgs e, RibbonHitInfo hitInfo)
bei DevExpress.XtraBars.Ribbon.Handler.BaseRibbonHandler.OnMouseUp(DXMouseEventArgs e)
bei DevExpress.XtraBars.Ribbon.Handler.RibbonHandler.OnMouseUp(DXMouseEventArgs e)
bei DevExpress.XtraBars.Ribbon.RibbonControl.OnMouseUp(MouseEventArgs e)
bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei DevExpress.Utils.Controls.ControlBase.WndProc(Message& m)
bei DevExpress.XtraBars.Ribbon.RibbonControl.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


Sometimes the git controls are greyed out, if i switch between other projects. Then i need to restart Powershell Studio.

Under Options\Source Control git is enabled
git.exe is under C:\Program Files\Git\cmd
git.inf is under C:\ProgramData\SAPIEN\Version Control Providers

Hope you can help me!

Regards

User avatar
mxtrinidad
Site Admin
Posts: 351
Joined: Sun Mar 03, 2013 12:42 pm

Re: Git not working

Post by mxtrinidad » Wed Sep 11, 2019 7:23 am

We are currently investigating the issue you're experiencing. By any chance, has the Git.inf file been modified?

User avatar
brittneyr
Site Admin
Posts: 186
Joined: Thu Jun 01, 2017 7:20 am

Re: Git not working

Post by brittneyr » Wed Sep 11, 2019 2:13 pm

We are aware of other customers experiencing the same issue with the Source Control buttons being grayed out and are working to resolve this issue.
As for the exception, when you go to clone, does one of the following dialogs pop up before or after you get the exception:
SPS_GITCloneInto.png
SPS_GITCloneInto.png (3.46 KiB) Viewed 698 times
SPS_GITCloneRemote.png
SPS_GITCloneRemote.png (4.22 KiB) Viewed 698 times
Brittney Ryn
SAPIEN Technologies, Inc.

sleddi
Posts: 3
Joined: Mon Sep 02, 2019 3:18 am

Re: Git not working

Post by sleddi » Thu Sep 12, 2019 10:43 pm

@mxtrinidad: I didn't changed the git.inf file
@brittneyr: No pop ups where shown

I reinstalled Powershell Studio and git Desktop twice. On another system i have the same problem.

If i start the git gui and type in the address of the repository it works like a charm.


Thanks for your fast reply!

User avatar
mxtrinidad
Site Admin
Posts: 351
Joined: Sun Mar 03, 2013 12:42 pm

Re: Git not working

Post by mxtrinidad » Fri Sep 13, 2019 6:33 am

Thanks for the reply! We haven't found the cause of the issue you're experiencing but are still investigating.

User avatar
mxtrinidad
Site Admin
Posts: 351
Joined: Sun Mar 03, 2013 12:42 pm

Re: Git not working

Post by mxtrinidad » Fri Sep 13, 2019 8:12 am

We found the root cause of the issue, and will be working to fix it for our next service release.

In a nutshell, the issue seems to only happen when there's an open unsaved script, and you try to clone a repository. This will cause the exception and restart PowerShell Studio.

The workaround is to open a saved script file so you can use the Git Clone button.

Thank You for reporting the issue!

sleddi
Posts: 3
Joined: Mon Sep 02, 2019 3:18 am

Re: Git not working

Post by sleddi » Mon Sep 16, 2019 2:40 am

Your workaround is working for me. Thank you for your very fast help.

mxtrinidad wrote:
Fri Sep 13, 2019 8:12 am
We found the root cause of the issue, and will be working to fix it for our next service release.

In a nutshell, the issue seems to only happen when there's an open unsaved script, and you try to clone a repository. This will cause the exception and restart PowerShell Studio.

The workaround is to open a saved script file so you can use the Git Clone button.

Thank You for reporting the issue!