Weird behavior from executable.

Ask your Windows PowerShell-related questions, including questions on cmdlet development!
Forum rules
Do not post any licensing information in this forum.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
DaveMcDonald
Posts: 14
Joined: Tue Sep 04, 2018 8:41 am

Weird behavior from executable.

Post by DaveMcDonald » Fri Jul 05, 2019 5:11 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio 2019 v5.6.165
32 or 64 bit version of product:(64 Bit)
Operating system:Windows 10 Enterprise
32 or 64 bit OS: (64 Bit)

*** Please add details and screenshots as needed below. ***

DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM

This is interesting. I only see this behavior on my computer so far.

When running as exe (screenshots attached in file).

1. I browse using foldermoderndialog, the resulting path is displayed in text box.

2. Third tab check boxes are now cut off. Last character is missing.

Screen shots of build settings in file.

I am at a loss why this would do this only on one pc (I have tested on a tablet, laptop (Same OS etc as above) and no issues.
screenshots.pdf
(230.09 KiB) Downloaded 25 times

User avatar
Alexander Riedel
Posts: 7021
Joined: Tue May 29, 2007 4:43 pm

Re: Weird behavior from executable.

Post by Alexander Riedel » Fri Jul 05, 2019 5:36 am

Do your computers have different resolutions and scaling factors?
Alexander Riedel
SAPIEN Technologies, Inc.

DaveMcDonald
Posts: 14
Joined: Tue Sep 04, 2018 8:41 am

Re: Weird behavior from executable.

Post by DaveMcDonald » Fri Jul 05, 2019 5:44 am

Most likely. But why would this only cut off the text in two check boxes?

User avatar
Alexander Riedel
Posts: 7021
Joined: Tue May 29, 2007 4:43 pm

Re: Weird behavior from executable.

Post by Alexander Riedel » Fri Jul 05, 2019 6:23 am

Scaling in Windows is a science in itself. Makes sure to size all check boxes, buttons, labels etc with as much extra horizontal space to account for variations in scaling factors, font sizes and different default fonts on different systems.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Weird behavior from executable.

Post by davidc » Fri Jul 05, 2019 8:41 am

This article may be of assistance to you:

https://info.sapien.com/index.php/guis/ ... i-displays
David
SAPIEN Technologies, Inc.

DaveMcDonald
Posts: 14
Joined: Tue Sep 04, 2018 8:41 am

Re: Weird behavior from executable.

Post by DaveMcDonald » Fri Jul 05, 2019 11:20 am

So now, I have one that is absolutely perplexing me.

When I play my form, everything seems to work as it should.

When I convert it to an executable (Build settings are the same) I am getting this error on exectution of start-job

ERROR: [localhost] The background process reported an error with the following message: .
ERROR: + CategoryInfo : OpenError: (localhost:String) [], PSRemotingTransportException
ERROR: + FullyQualifiedErrorId : 2100,PSSessionStateBroken

Attached is windows error message.
error.pdf
(41.08 KiB) Downloaded 10 times

User avatar
Alexander Riedel
Posts: 7021
Joined: Tue May 29, 2007 4:43 pm

Re: Weird behavior from executable.

Post by Alexander Riedel » Tue Jul 09, 2019 6:42 am

Without knowing exactly what your code does, that is hard to diagnose.
I will move this to the general PowerShell section.
But since it seems to involve remoting, I would look into permission and firewall settings.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 7021
Joined: Tue May 29, 2007 4:43 pm

Re: Weird behavior from executable.

Post by Alexander Riedel » Tue Jul 09, 2019 6:43 am

[Moved by moderator]
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
jvierra
Posts: 13718
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Weird behavior from executable.

Post by jvierra » Tue Jul 09, 2019 7:01 am

"Start-Job" spawns a new PowerShell instance. This is aborting when it tries to remote.

You say this only happens on one system. I would first suspect the system has an issue.

Locked