Deploy\Installer forgets files/reverts settings

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
EMHTSapien
Posts: 2
Joined: Tue Jul 25, 2017 7:57 am

Deploy\Installer forgets files/reverts settings

Post by EMHTSapien » Tue Feb 05, 2019 7:20 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: Powershell Studio 2019, 5.6.158, v10.0.14393.0
32 or 64 bit version of product: 64
Operating system: Windows 10 1607
32 or 64 bit OS: 64

*** Please add details and screenshots as needed below. ***

When using the MSI installer, settings and files are forgotten by PS studio.

Steps:

1. Open PS Project > Build a .exe with the packager
2. Installer > Settings > Files/Folder > Select Add Packager > input .exe
3. Add additional files
4. Select "Create shortcut to: (Packaged Executable)
5. Build
6. Go back into Installer > Settings > Files/Folder
7. See the last file added is missing and the Create Shortcut to: is now blank

This causes me to have to remove/add files and verify settings every time I build a new MSI. It does not seem to matter which type of file I'm adding.
Capture.PNG
Capture.PNG (26.38 KiB) Viewed 647 times

Thank you
Last edited by EMHTSapien on Tue Feb 05, 2019 8:24 am, edited 1 time in total.

User avatar
Alexander Riedel
Posts: 6952
Joined: Tue May 29, 2007 4:43 pm

Re: Deploy\Installer forgets files/reverts settings

Post by Alexander Riedel » Tue Feb 05, 2019 7:29 am

Please do not post license or subscription numbers in this forum!
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
EMHTSapien
Posts: 2
Joined: Tue Jul 25, 2017 7:57 am

Re: Deploy\Installer forgets files/reverts settings

Post by EMHTSapien » Tue Feb 05, 2019 8:23 am

Yea, I guess I didn't read close enough, I thought that was the build number. Thanks for the removal.

User avatar
davidc
Posts: 5889
Joined: Thu Aug 18, 2011 4:56 am

Re: Deploy\Installer forgets files/reverts settings

Post by davidc » Tue Feb 05, 2019 8:45 am

If you can, please zip and upload the project here:

https://www.sapien.com/support/upload

So that we can take a closer look at the issue.
David
SAPIEN Technologies, Inc.