WMI Explorer will not register

Use this forum to ask about non-product related topics (login issues, product registrations, web site questions, etc.) No technical support questions, please.
Forum rules
Do not post any licensing information in this forum.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
WoofWolf
Posts: 2
Joined: Fri Mar 31, 2017 1:32 pm

WMI Explorer will not register

Post by WoofWolf » Tue Aug 21, 2018 2:07 pm

Bought Studio, PrimalSQL and WMI Explorer. First two registered fine. WMI Explorer refuses with error GUI message, "The Certificate authority is invalid or incorrect."

Help?

User avatar
Alexander Riedel
Posts: 7096
Joined: Tue May 29, 2007 4:43 pm

Re: WMI Explorer will not register

Post by Alexander Riedel » Tue Aug 21, 2018 10:11 pm

Please post in the corresponding product forum and include the requested information about OS and product version.
Certificate errors usually stem from a missing root certificate for our digital signatures or the counter signatures for the time stamp.
Since we recently updated our signature (as they expire every other year) it is possible that your downloads have the old signature on PowerShell Studio and PrimalSQL but the new signature on WMI Explorer. Or vice versa, we cannot tell without version information.

I am assuming that with 'register' you mean 'install'. You can right click on the installer file, select 'Properties' and explore the details of the digital signatures and their counter signatures to see what root certificate might be missing.
Generally bringing your OS up to current patch levels should also update all common root certificates.

Please note that the above just states common occurrences for such an error. Without your exact version information it is not possible to check any details.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
WoofWolf
Posts: 2
Joined: Fri Mar 31, 2017 1:32 pm

Re: WMI Explorer will not register

Post by WoofWolf » Wed Aug 22, 2018 1:08 pm

Works fine after using offline license file.
BTW system is current on patching. WMI Explorer was downloaded the same day I bought it (yesterday).

Thanks anyway.