Cacheexport not working

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
Kosik174
Posts: 4
Meble kuchenne na zamówienie - na wymiar - Wrocław
Joined: Wed Sep 24, 2014 4:52 am

Cacheexport not working

Post by Kosik174 »

I tried to run the utility "CacheExport.exe" on server from version PowerShel Script 2015. The answer came to me that message is on next table. Please can you advise me? Previous versions - 2014 worked without problems.

Vladimir Kosiner
Attachments
cacheexport.JPG
cacheexport.JPG (22.62 KiB) Viewed 3044 times

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Cacheexport not working

Post by davidc »

It requires the Visual Studio 2012 C++ Redistributables to run properly.

You can download them from here:

http://www.microsoft.com/en-us/download/details.aspx?id=30679

David
David
SAPIEN Technologies, Inc.

User avatar
Kosik174
Posts: 4
Joined: Wed Sep 24, 2014 4:52 am

Re: Cacheexport not working

Post by Kosik174 »

After installing vcredist_x64.exe message remains the same. When you copy msf110u.dll to the directory where CacheExport.exe. Appears attached message.
Attachments
cacheexport1.JPG
cacheexport1.JPG (21.4 KiB) Viewed 3021 times

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Cacheexport not working

Post by davidc »

On what OS are you running the CacheExport?

David
David
SAPIEN Technologies, Inc.

User avatar
Kosik174
Posts: 4
Joined: Wed Sep 24, 2014 4:52 am

Re: Cacheexport not working

Post by Kosik174 »

Always on Windows Server 2012 R2.

Vladimir

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Cacheexport not working

Post by davidc »

Does the RegisterControls.exe fail as well?

David
David
SAPIEN Technologies, Inc.

User avatar
Nillth
Posts: 26
Joined: Thu Aug 01, 2013 6:14 pm
Location: Melbourne, Australia

Re: Cacheexport not working

Post by Nillth »

Kosik174 wrote:I tried to run the utility "CacheExport.exe" on server from version PowerShel Script 2015. The answer came to me that message is on next table. Please can you advise me? Previous versions - 2014 worked without problems.

Vladimir Kosiner
Hi Vladimir,

I have run in this issue a couple of time,
(Even have a support case open with David to get them to fix it in the build)

The Cache Builder running on a x64 machines (such as Server 2012 you are using) requires BOTH the x64 AND the x86 runtimes. vcredist_x64.exe & vcredist_x86.exe
Once both of these are installed it works.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: Cacheexport not working

Post by davidc »

Thank you for the update.

David
David
SAPIEN Technologies, Inc.

User avatar
Kosik174
Posts: 4
Joined: Wed Sep 24, 2014 4:52 am

Re: Cacheexport not working

Post by Kosik174 »

Excellent! The system works as it should!

Thank you.

Vladimir.