Error when trying to package file with "Run As User"

Archived support forum for customers who once purchased a PrimalForms product license. This forum is locked.
User avatar
nodgiles
Posts: 11
Joined: Tue Oct 30, 2012 2:49 am

Error when trying to package file with "Run As User"

Post by nodgiles »

***Even though I have registered my product I am unable to post in the subscriptions forum... I have attached a screenshot showing the registration of my product. Please correct this issue.***

Primal Forms 2011

After attempting to package a file with "Run As", I get an "Invalid Username or Password" error when I try to run the package. I have verified that both the username and password are correct. This happens with newly created accounts as well as existing accounts on my domain.

I am entering in the username as username@domain and I have verified the password is correct by logging onto other machines on my domain with this account.

Please advise.


Attached files

User avatar
nodgiles
Posts: 11
Joined: Tue Oct 30, 2012 2:49 am

Error when trying to package file with "Run As User"

Post by nodgiles »

So I found 1 account that is able to run the script, unfortunately that account is my domain admin account. Obviously I cant use this account permanently.

Finding that I could use my domain admin account, I created a new account by copying my domain admin account. I removed the big permissions such as Domain Admin, Storage Admin, etc. I attempted to package the file again, and a new error came up. With this newly created account (copied from a working account) I receive "The Directory Object Does Not Exist." I am able to log onto other machines using this new account.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Error when trying to package file with "Run As User"

Post by davidc »

Does the account have permission to create a user data folder? I.e. create a folder in the Application Data path or any other user folder.

David
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Error when trying to package file with "Run As User"

Post by davidc »

Also what build of PrimalForms 2011 are you running?

David
David
SAPIEN Technologies, Inc.

User avatar
nodgiles
Posts: 11
Joined: Tue Oct 30, 2012 2:49 am

Error when trying to package file with "Run As User"

Post by nodgiles »

I was thinking it may have something to do with local permissions. I added the user as a local admin on my build machine. I logged in as that user, attempted to package the file as that user with that same user as the "Run As" and I got the same result.

I'm running Primal Forms 2011 v2.0.26
I get the same result using Powershell Studio 2012 v3.0.8

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Error when trying to package file with "Run As User"

Post by davidc »

We will look into the issue. Just in case, please update PowerShell Studio to the latest build and try rebuilding the packaged exe to see if it makes a difference.

David
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Error when trying to package file with "Run As User"

Post by davidc »

What Platform / Engine are you using to package the exe?

David
David
SAPIEN Technologies, Inc.

User avatar
nodgiles
Posts: 11
Joined: Tue Oct 30, 2012 2:49 am

Error when trying to package file with "Run As User"

Post by nodgiles »

win7 x64

Updated powerstudio to 3.1.12 - same issue.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Error when trying to package file with "Run As User"

Post by davidc »

What Packager settings are you using?
CommandLine or Windows or Forms?
PowerShell V2 or V3?

David
David
SAPIEN Technologies, Inc.

User avatar
nodgiles
Posts: 11
Joined: Tue Oct 30, 2012 2:49 am

Error when trying to package file with "Run As User"

Post by nodgiles »

Powershell v2

Ive tried every combination of settings. None seem to work.