Packaged randomly builds non working executables

Archived support forum for customers who once purchased a PrimalForms product license. This forum is locked.
User avatar
tjirsch
Posts: 4
Joined: Tue Feb 21, 2012 10:33 pm

Packaged randomly builds non working executables

Post by tjirsch »

As of the latest versions of Primalforms the packager randomly builds non working executables.Starting with a working script/Project, it somtimes works after packaging, sometimes it does not.The error is not in the code, simply retrying to package (4-10) times works eventually,restarting Primalforms and repackagings helps.The error shows when trying to start the packaged application, Windows (7, 64bit, Server 2008 64bit) says: "Ther is a problem with the application, blabla" This is simply annoying. Furthermore, the signing of the executable stopped working completely, PF says "An exception occurred while signing the fileERROR: Unable to sign executable file" Nothing changed, exept the installed PF version.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Packaged randomly builds non working executables

Post by davidc »

What version of PrimalForms are you using? David
David
SAPIEN Technologies, Inc.

User avatar
tjirsch
Posts: 4
Joined: Tue Feb 21, 2012 10:33 pm

Packaged randomly builds non working executables

Post by tjirsch »

Version 2.0.20. Problems started about some minor builds earlier, the "unable to sign" error is new to version 2.0.20. The faulty executable problem is not specific to a project, even unchanged project sometimes do not run after repackaging.

User avatar
Alexander Riedel
Posts: 7378
Joined: Tue May 29, 2007 4:43 pm

Packaged randomly builds non working executables

Post by Alexander Riedel »

Please zip and email one of these faulty executables to support@sapien.com
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 7378
Joined: Tue May 29, 2007 4:43 pm

Packaged randomly builds non working executables

Post by Alexander Riedel »

Do you get any error messages when a non-working executable is produced? Are you packaging on a network drive or a local disk?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
tjirsch
Posts: 4
Joined: Tue Feb 21, 2012 10:33 pm

Packaged randomly builds non working executables

Post by tjirsch »

Everything looks normal, there are no error messages.The Project dir is on a network drive.

User avatar
tjirsch
Posts: 4
Joined: Tue Feb 21, 2012 10:33 pm

Packaged randomly builds non working executables

Post by tjirsch »

NB: Signing works perfectly with primalscript using the same certificate, both signing the script itself or the executable after packaging

User avatar
wlewis
Posts: 7
Joined: Mon Mar 19, 2012 6:18 am

Packaged randomly builds non working executables

Post by wlewis »

I have been experiencing the same issues with packaging.
(building non-working executables, not cert issues)
This happens on ~4 out of 5 attempts. Retrying (repeatedly) without changing any code or packaging preferences typically works. Same error returned every time.

"Error: Saving updated resources failed: 5"

Possibly related to the export issues where occasionally (most of the time) a new line is not inserted between 2 lines (typically in the "generated form code" region) causing errors when the script runs?

User avatar
Alexander Riedel
Posts: 7378
Joined: Tue May 29, 2007 4:43 pm

Packaged randomly builds non working executables

Post by Alexander Riedel »

Is this on a network or on a local drive?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
wlewis
Posts: 7
Joined: Mon Mar 19, 2012 6:18 am

Packaged randomly builds non working executables

Post by wlewis »

All files are stored locally.

On the export issue, it seems to appear most often with datagridview controls.

Code: Select all

$gap_dgv_Results.AutoSizeColumnsMode = 'AllCells' 
$System_Windows_Forms_DataGridViewCellStyle_1 = New-Object 'System.Windows.Forms.DataGridViewCellStyle'     
$System_Windows_Forms_DataGridViewCellStyle_1.Alignment = 'MiddleLeft' 
$System_Windows_Forms_DataGridViewCellStyle_1.BackColor = 'Control'
That same issue (2 lines in 1) with the middle line comes up 3 times for 1 control.wlewis2012-03-19 16:32:54