[PSS/PS 2015] PrimalSense: Recognize "#Requires -Modules"

Post feature requests, product enhancement ideas, and other product-specific suggestions here. Do not post bug reports.
Forum rules
Do not post any licensing information in this forum.
Locked
User avatar
danbarr
Posts: 6
Joined: Fri Sep 06, 2013 5:42 am

[PSS/PS 2015] PrimalSense: Recognize "#Requires -Modules"

Post by danbarr »

In both PowerShell Studio and PrimalScript 2015, PrimalSense does not recognize the "#Requires -Modules xxx" statement in v3+ scripts when deciding what Cmdlets to highlight or auto-complete. Also, the "Verify Script" featue of PSS 2015 reports "Missing Cmdlets" for modules which are covered by a #Requires -Modules statement.

Since "#Requires -Modules" will cause a module to be imported if not present, having a separate Import-Module statement in a script just to trigger PrimalSense is redundant. I know I can change the option to highlight all Cmdlets, but I'd rather still have some indicator that a module hasn't been covered by either an Import-Module or #Requires -Modules statement.

Thanks!
Dan

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: [PSS/PS 2015] PrimalSense: Recognize "#Requires -Modules

Post by davidc »

We will look into added support for this.

Thank you for bring this to our attention.

David
David
SAPIEN Technologies, Inc.

Locked