Problem when using autosign and saving

Use this forum to ask questions after your subscription maintenance expires or before you buy. Need information on licensing or pricing? Questions about a trial version? This is the right place for you. No scripting questions, please.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
gamblesk
Posts: 4
Joined: Fri Mar 06, 2020 10:13 am

Problem when using autosign and saving

Post by gamblesk »

Powershell Studio 5.7.172
Windows 10 Pro 1909

Work has started the process of moving us to using a VDI as a jumpbox to reach our database servers. As part of that process we are being asked to test the software we normally use before they start locking things down.

I have installed Powershell Studio on this jumpbox and I am having issues when signing a script. When I have powershell->automatically sign .ps1 scripts checked every time I try to save a script powershell studio pauses/hangs (using no CPU) for about 60 seconds then it returns saying that it Successfully Signed the file but it did not.

From outside powershell studio the signing works with no issues.
No errors in the event viewer.

Hoping someone might have seen this or have an idea what is happening during signing that might be causing the application to pause/hang like that and then say it was successful. Or where I might look. I suspect its more in the way they have restricted this jumpbox than it is a problem with Studio but I don't even know where else I might look for any errors/messages.

Scott

gamblesk
Posts: 4
Joined: Fri Mar 06, 2020 10:13 am

Re: Problem when using autosign and saving

Post by gamblesk »

I apologize I put this in the wrong forum some how. I meant to put it in the powershell studio form.. can it be moved or should I repost?

User avatar
brittneyr
Site Admin
Posts: 542
Joined: Thu Jun 01, 2017 7:20 am

Re: Problem when using autosign and saving

Post by brittneyr »

In a regular desktop environment, I'm not able to reproduce this behavior of not being able to sign, but I will keep investigating.
Also, please ensure that no components of PowerShell Studio are being blocked by a firewall, specifically a dll called SignScript.
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
brittneyr
Site Admin
Posts: 542
Joined: Thu Jun 01, 2017 7:20 am

Re: Problem when using autosign and saving

Post by brittneyr »

Your post was redirected here as there are no licenses associated with your account.
Brittney Ryn
SAPIEN Technologies, Inc.

gamblesk
Posts: 4
Joined: Fri Mar 06, 2020 10:13 am

Re: Problem when using autosign and saving

Post by gamblesk »

ok thanks. Looks like the key/license was registered by someone else in the company. I will try and figure that out.

gamblesk
Posts: 4
Joined: Fri Mar 06, 2020 10:13 am

Re: Problem when using autosign and saving

Post by gamblesk »

specifically a dll called SignScript.

That sounds promising these jumpboxes are definitely locked down. Would that be reaching out to the internet or are you referring to windows firewall blocking it just locally on the jumpbox itself.

User avatar
Alexander Riedel
Posts: 7458
Joined: Tue May 29, 2007 4:43 pm

Re: Problem when using autosign and saving

Post by Alexander Riedel »

Yes, timestamping while signing requires internet access to the timestamp URL specified in the options.
If you do NOT timestamp, the signature becomes invalid when the signing certificate expires.
Alexander Riedel
SAPIEN Technologies, Inc.