PrimalScript 2009 Packager not launching exe's

Use this forum to ask questions before you buy. Need information on licensing or pricing? Questions about a trial version? This is the right place for you. No scripting questions, please.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
obiwein
Posts: 18
Joined: Mon Dec 14, 2009 1:57 am

PrimalScript 2009 Packager not launching exe's

Post by obiwein » Sun Jan 31, 2010 11:00 pm

Is there a way to FTP the file to you or some method of transfer other than email? Our mail system will not allow the sending of exe files, exe files contained in zip files, or exe files renamed as another file type.

Please advise. Thanks.

User avatar
Alexander Riedel
Posts: 6861
Joined: Tue May 29, 2007 4:43 pm

PrimalScript 2009 Packager not launching exe's

Post by Alexander Riedel » Mon Feb 01, 2010 4:36 am

Just zip the file and rename it to .txt before sending
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 6861
Joined: Tue May 29, 2007 4:43 pm

PrimalScript 2009 Packager not launching exe's

Post by Alexander Riedel » Thu Feb 04, 2010 12:08 pm

ok, I got your file, which runs fine here but produces no output, which is a bit peculiar.
I noticed that you have a manifest added, which some XP systems don't like for command line files. I have packaged a powershell "get-date" script here and attached it here. See if that runs on your machine.
uploads/7840/Hello_from_Powershell.zip
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
obiwein
Posts: 18
Joined: Mon Dec 14, 2009 1:57 am

PrimalScript 2009 Packager not launching exe's

Post by obiwein » Mon Feb 08, 2010 2:05 am

It does indeed launch and seems to run although it closes almost immediately.

Next steps?obiwein2010-02-08 09:06:17

User avatar
obiwein
Posts: 18
Joined: Mon Dec 14, 2009 1:57 am

PrimalScript 2009 Packager not launching exe's

Post by obiwein » Mon Feb 08, 2010 2:10 am

Just tried the same package that was sent to you via email and it does not work on another workstation here.

User avatar
Alexander Riedel
Posts: 6861
Joined: Tue May 29, 2007 4:43 pm

PrimalScript 2009 Packager not launching exe's

Post by Alexander Riedel » Mon Feb 08, 2010 2:14 am

Well, it is a command line package, so you are supposed to run it from a command prompt.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 6861
Joined: Tue May 29, 2007 4:43 pm

PrimalScript 2009 Packager not launching exe's

Post by Alexander Riedel » Mon Feb 08, 2010 2:15 am

Does that workstation have powershell installed?
Can you define "not work"?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
obiwein
Posts: 18
Joined: Mon Dec 14, 2009 1:57 am

PrimalScript 2009 Packager not launching exe's

Post by obiwein » Mon Feb 08, 2010 2:23 am

Yes, PowerShell is installed on that other machine as well.

Not Work...
Returns this error:
"This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

User avatar
Alexander Riedel
Posts: 6861
Joined: Tue May 29, 2007 4:43 pm

PrimalScript 2009 Packager not launching exe's

Post by Alexander Riedel » Mon Feb 08, 2010 2:26 am

And this other machine is what OS?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 6861
Joined: Tue May 29, 2007 4:43 pm

PrimalScript 2009 Packager not launching exe's

Post by Alexander Riedel » Mon Feb 08, 2010 2:32 am

Install dependency walker on yor machine:
http://dependencywalker.com/

and check what dlls you don't have. That error indicates a side-by-side issue, most like related to missing runtimes, outdated comctl32 versions, can be anything.
Alexander Riedel
SAPIEN Technologies, Inc.