Installation problem

Use this forum to ask questions before you buy. Need information on licensing or pricing? Questions about a trial version? This is the right place for you. No scripting questions, please.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
boxikg
Posts: 10
Joined: Wed Apr 30, 2014 2:58 am

Installation problem

Post by boxikg » Mon Oct 30, 2017 2:53 am

Hi, I had some troubles with my laptop so I uninstalled PowerShell Studio 2017 along with other products installed automatically during PowerShell Studio 2017 installation (Document Explorer 2017, ScriptMerge 2017 and Updates). Afterwards new installation of PowerShell Studio 2017 does not install other products mentioned above. There are no errors during installation. How to solve this? In attachment screenshot of all SAPIEN products installed in first place is shown (before uninstallation).
SAPIENProducts.png
SAPIENProducts.png (7.89 KiB) Viewed 4018 times

User avatar
Alexander Riedel
Posts: 6359
Joined: Tue May 29, 2007 4:43 pm

Re: Installation problem

Post by Alexander Riedel » Mon Oct 30, 2017 3:12 am

I am not certain why that would happen. I will hand it to QA to see what they can find out. I recommend manual uninstall and reinstall. Sometimes when products are not installed, the Windows Installer registry keys make MSI believe the product is still installed and up-to-date. Not knowing what kind of troubles you had I can only guess, but maybe your registry did get partially restored and that is the result of that.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
boxikg
Posts: 10
Joined: Wed Apr 30, 2014 2:58 am

Re: Installation problem

Post by boxikg » Mon Oct 30, 2017 3:34 am

You were right. Some lingering keys were still there in registry even after manual uninstallation. I deleted all of them and Document Explorer, ScriptMerge and Updates have been successfully installed. This is workaround but problem should be solved anyway - every uninstall process should leave file/registry locations completely clean without any leftovers from uninstalled software. I am very experienced in working with registry but ordinary user might easily make some wrong move :D.