WPF -> Sapien Powershell -> Exe - UI doesnt show properly

Use this forum to ask questions after your subscription maintenance expires or before you buy. Need information on licensing or pricing? Questions about a trial version? This is the right place for you. No scripting questions, please.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
cowburner
Posts: 1
Last visit: Fri Aug 13, 2021 1:02 am

WPF -> Sapien Powershell -> Exe - UI doesnt show properly

Post by cowburner »

Hey Everyone,

Am experiencing a bit of an issue in terms of my GUI when using an exe file from a WPF created GUI.
Hope someone has experience with this :)

Basically, I've created my GUI in Visual Studio - and then I've merged the script with the GUI in Sapien Powershell Studio.
When I run the script from Powershell Studio - all looks perfect. All is exactly as should be.(Attached file - Sapien-Whentesting.png - supposed to be without logo)
When I then build my exe file, it cuts off the bottom - so the script ends up missing the bottom 15-20%.
(Attached files - Sapien-TooSmall - as it loads (incorrectly), and Sapien-Fullwindow (which is when I drag the bottom part down and it creates a white box at the top)).

Have anyone else seen similar issues - and more importantly; does anyone have any suggestions? :)
It's a multiple file (xaml and logo files) exe file.
I've worked on auto-adjustment settings with no success.

Thanks in advance
Best regards
Henrik
Attachments
Sapien-Whentesting.png
Sapien-Whentesting.png (89.89 KiB) Viewed 6391 times
Sapien-TooSmall.png
Sapien-TooSmall.png (127.43 KiB) Viewed 6391 times
Sapien-Fullwindow.png
Sapien-Fullwindow.png (111.73 KiB) Viewed 6391 times

User avatar
brittneyr
Site Admin
Posts: 854
Last visit: Mon Sep 20, 2021 3:26 pm
Answers: 17
Been upvoted: 15 times

Re: WPF -> Sapien Powershell -> Exe - UI doesnt show properly

Post by brittneyr »

What script engine are you using when packaging?

Can you upload a sample project demonstrating this behavior:
https://www.sapien.com/support/upload
Brittney Ryn
SAPIEN Technologies, Inc.