Page 1 of 1

Cannot install module

Posted: Fri Mar 15, 2019 8:10 am
by mpenton
Hello,


I've registered Powershell gallery in my repo, and am trying to install PSGSuite from it.

When I try to install I get the error "Failed to install version 2.24.0 of PSGSuite".

Previously I had PSGSuite installed manually. It showed in ModuleManager as a "User Module", but I used the Disable feature to remove it, so I can install it via the repo. Maybe this is the issue?

Here's my log output:
=====

>> Installing dependent package 'Configuration'
>>
>> Downloaded 0.00 MB out of 0.04 MB.
>> Downloaded 0.02 MB out of 0.04 MB.
>> Downloaded 0.03 MB out of 0.04 MB.
>> Downloaded 0.04 MB out of 0.04 MB.
>> Downloaded 39435.00 MB out of 39435.00 MB.
>> Unzipping
>> Copying unzipped package to 'C:\Users\xxxxxx\AppData\Local\Temp\397327220\Configuration'
>> Process Package Manifest
>> Finish installing package 'Configuration'
>> Completed.
>> Installed dependent package 'Configuration'
>> Downloaded 0.00 MB out of 3.74 MB.
>> Downloaded 0.37 MB out of 3.74 MB.
>> Downloaded 0.75 MB out of 3.74 MB.
>> Downloaded 1.12 MB out of 3.74 MB.
>> Downloaded 1.50 MB out of 3.74 MB.
>> Downloaded 1.87 MB out of 3.74 MB.
>> Downloaded 2.25 MB out of 3.74 MB.
>> Downloaded 2.62 MB out of 3.74 MB.
>> Downloaded 3.00 MB out of 3.74 MB.
>> Downloaded 3.37 MB out of 3.74 MB.
>> Downloaded 3923556.00 MB out of 3923556.00 MB.
>> Unzipping
>> Copying unzipped package to 'C:\Users\xxxxxx\AppData\Local\Temp\397327220\PSGSuite'
>> Process Package Manifest
>> Finish installing package 'PSGSuite'
>> Completed.
>> Verifying install...
>> Unable to verify install...
>> Failed to install version 2.24.0 of PSGSuite.

Re: Cannot install module

Posted: Fri Mar 15, 2019 8:48 am
by brittneyr
Thanks for reporting your issue.
Can you please provide the following information?
Product, version and build:
32 or 64 bit version of product:
Operating system:
32 or 64 bit OS:

What version of PSGSuite did you have installed previously?

Re: Cannot install module

Posted: Fri Mar 15, 2019 8:56 am
by mpenton
ModuleManager 1.1.0 64 bit
Windows 7 64bit

PSGSuite 2.24.0

Re: Cannot install module

Posted: Fri Mar 15, 2019 11:11 am
by brittneyr
When you say you installed it 'manually', do you remember how you installed it? Did you use the cmdlet:
  1. Install-module

Re: Cannot install module

Posted: Fri Mar 15, 2019 12:02 pm
by mpenton
Yes that's right.

Re: Cannot install module

Posted: Fri Mar 15, 2019 12:16 pm
by brittneyr
The issue has been sent to the proper place for evaluation and correction. When a fix is issued with a service build, it will be listed in the change log.