Frustrating upgrade to 169

Use this forum to ask questions about installation or issues encountered while installing our software.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
owinsloe
Posts: 82
Joined: Tue Jul 10, 2012 10:37 am

Frustrating upgrade to 169

Post by owinsloe » Wed Oct 30, 2019 4:19 pm

Product: PowerShell Studio 2019 (64 Bit)
Build: v5.6.169
OS: Windows 10 Enterprise (64 Bit)
Build: v10.0.18362.0

WOW!....where do I start?

I have had a number of issues with the PSS upgrades in the past and this latest version was no exception. I managed to successfully install 169 by using the installer at the download page.

Maybe things could be improved with a few changes, as follows;

I noticed that updates were available from the new(?) yellow icon...image 1

This install process was knew to me, but, what-the-hay, decided to follow my nose and see what happens. Now presented with...image 2

Clicked on the link and got the Sapien Updates, slightly different to the one in the PDF (image 3) as the install failed and (image 3) was what came up when I retried the process.

After attempting the "download & install" I am presented with...image 4
This was quite annoying as I know from past experience that if you interrupt the install process, that's when things get messy (for me at least). The dialog asks "...Would you like to terminate these processes?.." and then presents you with [cancel] [try again] [continue]???? I would have thought YES/NO would be the way to go as 'try again' & "continue" seem to be synonymous?

Can't recall the order of events from here, pretty sure I tried both "try again" & "continue", anyway, the net result was (image 5) and eventually I went back to my earlier posts and found that I was directed to the download page, which is what I did and finally had success.

Some further notes..
If the download fails, perhaps the "corrupt archive" could be removed and then retry. If unable to remove the archive then post a notification to say where and what it is and allow the user to manually remove it.

If downloads continue to fail then why not flip up a dialog that directs the user to the download page location.

I tried adding the images in the pdf as individual attached images to this pane and after 3 images, clicking on the attachment button did nothing! There was no indication that I had exceeded a size or number limit?

All-in-all, not a pleasing experience. I hope these notes aid in correcting some of these issues and offering a more pleasurable user experience on my next upgrade.

Thanks
Document1.pdf
(386.49 KiB) Downloaded 12 times

User avatar
owinsloe
Posts: 82
Joined: Tue Jul 10, 2012 10:37 am

Re: Frustrating upgrade to 169

Post by owinsloe » Wed Oct 30, 2019 4:50 pm

OH, forgot to mention...
While I am now currently up-to-date with updates, the yellow ICON is still present and when you click on it there is still the dialog that tells me updates are available and if you click on that I get the install dialog that tells me that I am up-to-date, all rather messy!

User avatar
owinsloe
Posts: 82
Joined: Tue Jul 10, 2012 10:37 am

Re: Frustrating upgrade to 169

Post by owinsloe » Wed Oct 30, 2019 6:15 pm

Uh-huh....I need to 'dismiss all' to remove the YELLOW ICON prompt, that's a bit antiquated :?

User avatar
brittneyr
Site Admin
Posts: 235
Joined: Thu Jun 01, 2017 7:20 am

Re: Frustrating upgrade to 169

Post by brittneyr » Thu Oct 31, 2019 7:15 am

I apologize for the problems you have encountered while attempting to update. Thank you for the feedback and we will investigate the behaviors you have mentioned.
Brittney Ryn
SAPIEN Technologies, Inc.