Problem with installation from PowerShell Studio. "Automatic" Cancel

Use this forum to ask questions about installation or issues encountered while installing our software.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
davidc
Posts: 5439
Joined: Thu Aug 18, 2011 4:56 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by davidc » Mon Jul 09, 2018 7:24 am

Try specifying a log path is accessible to all users:

Code: Select all

(installername).exe /qn /L*V "c:\SomeSharedFolder\SPS_Install.log"
As for .NET installer, I just wanted to make sure that the .NET version wasn't the issue.
David
SAPIEN Technologies, Inc.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Mon Jul 09, 2018 7:59 am

I did that but it didn't work either.
No log file created.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Thu Jul 19, 2018 7:13 am

Isn't it possible to install PowerShell Studio with a workaround?
For example with a small installer that doesn't check all requirements?

At the moment I can't use PowerShell Studio.

Thank you.

User avatar
davidc
Posts: 5439
Joined: Thu Aug 18, 2011 4:56 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by davidc » Thu Jul 19, 2018 7:49 am

Typically, a silent install bypasses the prerequisite installs:

Code: Select all

(installername).exe /exenoui /qn
Unfortunately, we have not been about to reproduce this on any of our test machines but we will continue to try.

Another possibility is that the .NET install is corrupted. Can you try a repair or reinstall of 4.7? I will also look at adding a manual bypass to the installer.
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5439
Joined: Thu Aug 18, 2011 4:56 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by davidc » Thu Jul 19, 2018 8:00 am

Also check that you have the Visual C++ 2017 runtimes installed (x64 & x86):

https://visualstudio.microsoft.com/downloads/
David
SAPIEN Technologies, Inc.

User avatar
vobawf
Posts: 9
Joined: Wed Feb 14, 2018 9:35 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by vobawf » Thu Jul 19, 2018 8:07 am

Didn't work with the command line.

Here the last part of the log file I created.

Code: Select all

Action start 17:01:54: AI_ChooseTextStyles.
MSI (c) (EC:50) [17:01:54:271]: Invoking remote custom action. DLL: C:\Users\xxxxx\AppData\Local\Temp\MSI89C2.tmp, Entrypoint: ChooseTextStyles
MSI (c) (EC:88) [17:01:54:272]: Cloaking enabled.
MSI (c) (EC:88) [17:01:54:272]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (EC:88) [17:01:54:273]: Connected to service for CA interface.
MSI (c) (EC!E0) [17:01:54:343]: PROPERTY CHANGE: Modifying InputCtrlFont property. Its current value is '{\InputCtrlFont}'. Its new value: '{\InputCtrlFontGray}'.
MSI (c) (EC!E0) [17:01:54:343]: PROPERTY CHANGE: Modifying BrandingStyle property. Its current value is '{\BrandingStyle}'. Its new value: '{\BrandingStyleGray}'.
Action ended 17:01:54: AI_ChooseTextStyles. Return value 1.
MSI (c) (EC:CC) [17:01:54:346]: Doing action: AI_DpiContentScale
Action 17:01:54: AI_DpiContentScale. 
Action start 17:01:54: AI_DpiContentScale.
MSI (c) (EC:3C) [17:01:54:348]: Invoking remote custom action. DLL: C:\Users\xxxxx\AppData\Local\Temp\MSI8A11.tmp, Entrypoint: DpiContentScale
MSI (c) (EC!F8) [17:01:54:375]: PROPERTY CHANGE: Adding AI_SYSTEM_DPI property. Its value is '96'.
MSI (c) (EC!F8) [17:01:54:375]: PROPERTY CHANGE: Adding AI_SYSTEM_DPI_SCALE property. Its value is '100'.
Action ended 17:01:54: AI_DpiContentScale. Return value 1.
MSI (c) (EC:CC) [17:01:54:376]: PROPERTY CHANGE: Adding AI_BOOTSTRAPPERLANG property. Its value is '1033'.
MSI (c) (EC:CC) [17:01:54:378]: Note: 1: 2205 2:  3: MultipleInstances 
MSI (c) (EC:CC) [17:01:54:378]: Note: 1: 2228 2:  3: MultipleInstances 4: SELECT `InstKey`,`InstancesId`,`Order` FROM `MultipleInstances` 
MSI (c) (EC:CC) [17:01:54:378]: Note: 1: 2205 2:  3: MultipleInstancesProps 
MSI (c) (EC:CC) [17:01:54:378]: Note: 1: 2228 2:  3: MultipleInstancesProps 4: SELECT `Instance`,`PropertyName`,`PropertyValue` FROM `MultipleInstancesProps` 
MSI (c) (EC:CC) [17:01:54:378]: PROPERTY CHANGE: Deleting AI_BOOTSTRAPPER property. Its current value is '1'.
MSI (c) (EC:CC) [17:01:54:379]: PROPERTY CHANGE: Modifying AI_UNINSTALLER property. Its current value is 'msiexec.exe'. Its new value: 'C:\ProgramData\Caphyon\Advanced Installer\{48C84DD4-3706-4608-B0FD-262B75A66AD4}\SPS18Setup_5.5.152.0_XXXXXX_x64.exe'.
MSI (c) (EC:CC) [17:01:54:397]: Doing action: UserExit
Action 17:01:54: UserExit. 
Action start 17:01:54: UserExit.
Action ended 17:01:54: UserExit. Return value 0.
MSI (c) (EC:54) [17:01:54:398]: Destroying RemoteAPI object.
MSI (c) (EC:88) [17:01:54:399]: Custom Action Manager thread ending.
=== Verbose logging stopped: 19.07.2018  17:01:54 ===
I am off now for a week. I will check the points you wrote and respond then.
Thank you for your support.

User avatar
davidc
Posts: 5439
Joined: Thu Aug 18, 2011 4:56 am

Re: Problem with installation from PowerShell Studio. "Automatic" Cancel

Post by davidc » Thu Jul 19, 2018 10:08 am

We are unable to reproduce this. Can you try installing PowerShell HelpWriter or PrimalSQL to see if you encounter the same issue.

Also, if you have access to another machine on your network, try installing PowerShell Studio on that.
David
SAPIEN Technologies, Inc.

Locked