Page 1 of 1

Import/Create with Custom Types

Posted: Wed Oct 21, 2015 9:02 am
by kmkirkpatrick
When creating a new help file and importing from an existing module that has custom .NET types I get two errors. In this particular case, I have cmdlets in the module that specify .NET Types that get loaded as part of VMware's PowerCLI PSSnapIn.

The first error I get looks like this:
pshw_error1.PNG
Error 1
pshw_error1.PNG (35.45 KiB) Viewed 4779 times
The second error is just a blank window:
pshw_error2.PNG
Error 2
pshw_error2.PNG (31.85 KiB) Viewed 4779 times
After clicking through these, the import process hangs and I have to cancel out.

It appears that since the PowerCLI .NET types get loaded just-in-time, PSHW is not aware of them?

Any help is much appreciated.

Platform
---------------------
PSHW Version: 1.0.15
OS: Windows 7 x64
PS Version: 5.0.10514.6
Installed Sapien Products: PS Studio 2015, WMI Explorer 2015, Productivity Pack 2015

Import/Create with Custom Types

Posted: Wed Oct 21, 2015 9:02 am
by SAPIEN Support Forums
This is an automated post. A real person will respond soon.

Thank you for posting, kmkirkpatrick.

Did you remember to include the following?
  • 1. Product, version and build (e.g. Product: PowerShell Help Writer 2015, Version & Build: 1.0.9. Version and build information can be found in the product's About box accessed by clicking the blue icon with the 'i' in the upper right hand corner of the ribbon.)
    2. Specify if you are running a 32 or 64 bit version
    3. Specify your operating system and if it is 32 or 64 bit.
    4. Attach a screenshot if your issue can be seen on the screen
    5. Attach a zip file if you have multiple files (crash reports, log entries, etc.) related to your issue.
If not, please take a moment to edit your original post or reply to this one.

*** Make sure you do not post any licensing information ***

Re: Import/Create with Custom Types

Posted: Wed Oct 21, 2015 12:03 pm
by juneblender
When you run Get-Command -Module <ModuleName> on the cmdlets/functions in your module, are the results accurate? In particular, the command syntax and parameter attributes?

Re: Import/Create with Custom Types

Posted: Wed Oct 21, 2015 1:20 pm
by kmkirkpatrick
June,

It works when I have the PowerCLI PSSnapin loaded, but errors if I have not loaded the PSSnapin, which is what I expected.

Re: Import/Create with Custom Types

Posted: Wed Oct 21, 2015 1:48 pm
by juneblender
That makes sense. Since 3.0, PowerShell is optimized for managing modules, but the optimizations, like module auto-loading, don't affect snap-ins.

Let's see if David comes up with a solution for your help file.

Re: Import/Create with Custom Types

Posted: Wed Oct 21, 2015 3:41 pm
by davidc
We are attempting to recreate the issue.

David