Blank pop up while exporting help from module

Support for all customers who have purchased a PowerShell HelpWriter product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
gaelcolas
Posts: 1
Joined: Tue Apr 12, 2016 9:04 am

Blank pop up while exporting help from module

Post by gaelcolas » Thu May 12, 2016 2:08 pm

Product, version and build: 1.1.20
32 or 64 bit version of product: 64Bit
Operating system: Windows 10 (TP Fast ring, but it was also doing it in GA)
32 or 64 bit OS: 64bit

Hi,

I've tried to load one of my module in development to generate help file based on the syntax, but it starts and after a bit (~1min) then a blank pop up comes up (as per screenshot).
It looks like it still generates the file, and from a quick glance all functions directly defined in the file are imported.
Some command proxy help are forwarded as per the tags:
.ForwardHelpTargetName Microsoft.PowerShell.Utility\Write-Host
.ForwardHelpCategory Cmdlet

My module is on github if you want to try: https://github.com/gaelcolas/log4ps

I suspect that it can be two problems, maybe together:
- A memory issue or similar
- The fact that I use dynamic param extensively

My github uses git submodules to reference one of my other library (lib.common), so if you download only the zip file for log4ps, it will NOT download that dependency (github is not perfect, yet).
You need to either git clone recursively:
git clone --recursive git://github.com/gaelcolas/log4ps.git
Or if using the zip, you need to also download https://github.com/gaelcolas/lib.common and extract to the log4ps/lib folder.


Let me know if any question.

Gael
Attachments
sapien_3.png
After a while, blank pop up
sapien_3.png (42.05 KiB) Viewed 9477 times
sapien_2.png
Selecting module
sapien_2.png (40.78 KiB) Viewed 9477 times

User avatar
juneblender
Posts: 93
Joined: Thu Jul 24, 2014 3:26 pm

Re: Blank pop up while exporting help from module

Post by juneblender » Thu May 12, 2016 2:21 pm

Hi, Gael! Thanks for taking the time to explain and post on the forum. I'll download the module and see if I can reproduce it, then work with my colleagues on the dev team.

Best wishes,
June