Synopsis not exported

Support for all customers who have purchased a PowerShell HelpWriter product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
pdearmen
Posts: 59
Joined: Sun Mar 03, 2013 12:42 pm

Synopsis not exported

Post by pdearmen » Wed May 09, 2018 8:18 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: Powershell Help Writer 2018, version 2.2.39
32 or 64 bit version of product: 64 bit
Operating system: Windows 10 Fall Creators Update fully patched
32 or 64 bit OS: 64

*** Please add details and screenshots as needed below. ***

DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM

When generating an HTML file or Markdown file from help writer using File To Markdown or File To HTML, the Synopsis and notes headers are present but no data is present. If I use the CMDLET to Markdown or CMDLET to HTML option instead, the data is present under the headers. Another thing I noticed is that under Outputs, if I have nothing in the outputs area for the file when using File to Markdown/HTML it shows system.object but if using Cmdlet to Markdown/HTML the Output header has no data under it. I can provide the XML file I am seeing this issue on upon request if needed.

User avatar
Olga_B
Site Admin
Posts: 68
Joined: Mon May 15, 2017 9:06 am

Re: Synopsis not exported

Post by Olga_B » Wed May 09, 2018 8:41 am

Yes, please upload XML file here
https://www.sapien.com/support/upload

User avatar
pdearmen
Posts: 59
Joined: Sun Mar 03, 2013 12:42 pm

Re: Synopsis not exported

Post by pdearmen » Wed May 09, 2018 9:31 am

I have uploaded the file as requested.
Before I uploaded it I did run Validate Help Schema and there were 0 errors and 0 warnings on the file.

Please let me know if there is anything else I can provide to assist.

User avatar
Olga_B
Site Admin
Posts: 68
Joined: Mon May 15, 2017 9:06 am

Re: Synopsis not exported

Post by Olga_B » Wed May 09, 2018 9:53 am

Thanks. I will try to reproduce it on our environment, and let you know

User avatar
Olga_B
Site Admin
Posts: 68
Joined: Mon May 15, 2017 9:06 am

Re: Synopsis not exported

Post by Olga_B » Wed May 09, 2018 10:34 am

Hi,

I need more clarifications.
- How did you create original XML file?
- Did you use HelpWriter Designer mode?
- When i open your file in Designer mode the Synopsis and Note fields are empty. There is no data in original file, means nothing can be added to HTML
PHW-customer.png
PHW-customer.png (103.54 KiB) Viewed 1682 times

User avatar
pdearmen
Posts: 59
Joined: Sun Mar 03, 2013 12:42 pm

Re: Synopsis not exported

Post by pdearmen » Thu May 10, 2018 10:55 am

I opened the copy of the file I sent you as well as the copy on my hard drive in another PowerShell helpwritter window - and lo and behold those sections are blank as well. My computer did not reboot overnight, and I still had the windows for my PowerShell Helpwriter open from yesterday. On my session from yesterday the data was present where it is blank in the new window as well as your screenshot. I did another set of exports and encountered the same issue. I then clicked on exit in xml and noticed the data was not present in the xml. When I clicked on Edit In Designer - the fields are blank as shown in your screenshot as well.

I closed the file without saving and upon opening - the fields were empty as well. I copy and pasted the data from the exports into the fields and am now no longer able to reproduce the issue with the exports and the data shows in the edit in xml field.

I originally created the file through the new help file from module command. As of today I am unable to reproduce the issue. I guess unless it comes up again nothing more can be done. If it does I'll see if I can make a few copies of the files as I go through the process.

Thanks for the followup!

User avatar
Olga_B
Site Admin
Posts: 68
Joined: Mon May 15, 2017 9:06 am

Re: Synopsis not exported

Post by Olga_B » Thu May 10, 2018 11:31 am

Thanks for update.