Page 1 of 2

VersionRecall Explorer not referencing the correct files

Posted: Sun Sep 07, 2014 12:33 pm
by mattseale
x64 - version 1.0.99 - installed on Windows 8.1

Just purchased and installed Version Recall, as I want to use it with PowerShell Studio.

I setup a repository with the sourcefiles on my C: drive and the repository target on my D: Drive

When I change a file on disk and then click submit through the Version Recall Explorer, it increments the file versions count by one (in the explorer window, expected behaviour). But when you then browse the versions within the Explorer it doesn't match the files on disk...
capture.jpg
capture.jpg (127.66 KiB) Viewed 6577 times
In the attachment, bottom left image is the source (on C), filename used is test.txt - top left shows the repository folder, version created as @@1 file - this is all expected behaviour...the issue is within the Versions tab through the Version Recall explorer it shows the local file and the last submit file correctly, but the old version is shown as version 2 - in the blue bar at the bottom it shows it is looking for an @@2 file, when on disk only @@1 has been created.

I hope this makes sense and someone has a solution to this, as currently this product is unfit for my purpose.

This behaviour is consistently reproducible the explorer always looks for a file incremented one more than is on disk.

Strange thing is...if I right-click (within Windows Explorer) the file in the source folder and select versions from the context menu, I can browse the previous versions correctly.

Would really appreciate some help with this, thanks.

Re: VersionRecall Explorer not referencing the correct files

Posted: Sun Sep 07, 2014 2:50 pm
by Alexander Riedel
Sounds like a classic +1 bug. I will investigate and see what I can find out.

Re: VersionRecall Explorer not referencing the correct files

Posted: Sun Sep 07, 2014 4:15 pm
by Alexander Riedel
A new service build (1.0.100) was issued that should address this problem.

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 12:33 am
by mattseale
Many thanks, that seems to have fixed the issue (I will do some more testing today and confirm).

Another issue, not sure if its a result of this new release or not...when I use the Submit file option through PowerShell Studio it doesn't do anything:
capture2.jpg
capture2.jpg (15.03 KiB) Viewed 6550 times
Powershell Studio 2014 - x64 - version 4.1.67

Really appreciate the quick response to the first issue :)

Do you publish a change log to see what has changed/fixed by each release?

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 1:58 am
by Alexander Riedel
We are working on a release notes system. But we are a bit short staffed at the moment so we only post in the blog if there is something really important.

I will get the PowerShell Studio guys to look at the issue.
Can you specify how you verify that nothing happens?
I know they will ask :-)

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 2:53 am
by mattseale
If I am working on a file in PowerShell Studio and then click on the Tools menu, submit file (under VersionRecall block shown in previous screenshot), nothing happens - as in no confirmation, no file version created in the repository directory. The version only gets created when the VersionRecall service runs every 30mins.

Maybe I misunderstand the workflow, but I would assume that doing this would instantly submit a new version of the file to the repository?

I will continue my testing for the original issue and report back later today (UK time). Thanks for your help!

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 9:22 am
by davidc
The PowerShell Studio issue will be resolved in the next service build.

David

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 9:39 am
by mattseale
Ok, thanks.

Do you have an approximate ETA on the next release?

I have one other issue with PowerShell studio (when you click to open a file there is a long delay before the open dialog appears), but I will create a separate post for that.

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 10:00 am
by davidc
We have no ETA at the moment.

David

Re: VersionRecall Explorer not referencing the correct files

Posted: Mon Sep 08, 2014 2:45 pm
by mattseale
Thanks Alexander & David, my issues now seem to be fixed with the exception of the ability to instantly submit a new version from within PowerShell Studio.

I await the next service release and will then report back.