Build 1.0.47

Support for all customers who have purchased a VersionRecall product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
jhicks
Posts: 1789
Joined: Sun Jan 21, 2007 11:31 pm

Build 1.0.47

Post by jhicks » Tue Jul 16, 2013 7:25 pm

Ran into issues with latest build. Clicked the 64bit link to download. Install failed. Was prompted to close Windows Explorer and stop service. Service was stopped and I continued, then I got an error about failing to register a dll. At that point Windows basically crashed except for 2 PowerShell sessions I had open. No Explorer process or any other windows.

Rebooted. Ran the install again. This worked without error. I checked the about screen in the new version and it indicates I'm running 32bit. Yet the download file has x64 in the name. Task manager doesn't indicate that it is a 32bit app but I'm not really sure.

Finally, I see the change you made in the Repository tab. But personally I find this more confusing. To open a repository I actually have to click on a recent file which isn't intuitive at all. I liked the earlier builds which I think said, Recent Repositories or something like that.

User avatar
Alexander Riedel
Posts: 6873
Joined: Tue May 29, 2007 4:43 pm

Re: Build 1.0.47

Post by Alexander Riedel » Wed Jul 17, 2013 1:26 am

Depending on usage the service maybe in the middle of updating a repository. Or the Explorer plugin refuses to unload, which mostly happens mostly if you don't run Windows Explorer instances in separate processes.

So it probably will always be best to uninstall the previous version (which may require a reboot because of Windows Explorer) and then install the new build. If this happens again please include which dll.

As for the repository tab, I am not certain what you mean. There have been no changes to that in recent builds.

The 32 bit thing in the about box was just a missing define.
Process Explorer always knows best :-)
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
jhicks
Posts: 1789
Joined: Sun Jan 21, 2007 11:31 pm

Re: Build 1.0.47

Post by jhicks » Wed Jul 17, 2013 4:58 am

I realize uninstalling is always preferable but people don't. They assume the application will update the current install. If something needs to be uninstalled, the installation process handles it for them.

As for the tab issue, when I click on the Repository tab I now see Recent Documents and Recent Places. I thought it used to only show repository names. Now under recent documents I see things like Scripts.recall and Presentations.recall.

User avatar
Alexander Riedel
Posts: 6873
Joined: Tue May 29, 2007 4:43 pm

Re: Build 1.0.47

Post by Alexander Riedel » Wed Jul 17, 2013 10:04 am

Yes. Unfortunately it seems MSIE has a problem with Explorer extensions. We are working on it.

The Recent Documents has not changed. Not sure what to say :-)
Alexander Riedel
SAPIEN Technologies, Inc.