Page 3 of 4

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 7:56 am
by jvierra
Did you send an exe only? What was the error? Execution poicy would not cause this issue.

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:20 am
by tirwin@iot.in.gov
OK, the following is just a form with a Browse button. But when I compiled it to .exe I checked the "STA Mode" box and when I reopened the "Engine Settings" dialog the check box was still checked. This functionality is not working in my "Original Program". When I check the "STA Mode" box and reopen it. It alw
FolderModernDialog.psf
(10.09 KiB) Downloaded 89 times
ays comes back unchecked. What could be causing this behavior?

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:22 am
by dan.potter
jvierra wrote:Did you send an exe only? What was the error? Execution poicy would not cause this issue.

yes, it's on page 1.

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:29 am
by jvierra
There is a file in the folder with the PSF called "FolderModernDialog.psf.psbuild" and one called "FolderModernDialog.exe.config". Can you zip both of those and upload them,

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:35 am
by tirwin@iot.in.gov
Yes here you are. Again though that one is working.
Dialog.zip
(5.79 KiB) Downloaded 95 times

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:41 am
by jvierra
tirwin@iot.in.gov wrote:Yes here you are. Again though that one is working.
Dialog.zip
Are you saying that this simple version works correctly?

If that is so then copy your original PSF t a new folder and try to build it again after checking the engine and STA mode.

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:43 am
by jvierra
I also asked two different file and you do not end them'
Read my request"

FolderModernDialog.psf.psbuild
FolderModernDialog.exe.config

That is not what you sent.

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 8:59 am
by tirwin@iot.in.gov
is this what you need?
Dialog (2).zip
(951 Bytes) Downloaded 98 times

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 9:33 am
by tirwin@iot.in.gov
Moving all the files to another folder and then recompiling worked. Thanks

Re: FolderBrowserModernDialog not working in compiled .exe

Posted: Tue Jan 19, 2016 9:37 am
by tirwin@iot.in.gov
Moving all the files to another folder and then recompiling worked. Thanks