Can't build MSI

Ask questions about creating Graphical User Interfaces (GUI) in PowerShell and using WinForms controls.
Forum rules
Do not post any licensing information in this forum.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
User avatar
stevens
Posts: 416
Meble kuchenne na zamówienie - na wymiar - Wrocław
Joined: Wed Jun 15, 2016 2:26 am

Can't build MSI

Post by stevens »

Hi,

I can't build MSI anymore.Note that I changed the scriptsfolder from C:\Sapien to C:\My OneDrive\Sapien.
If I press the MSI cration button but nothing happens, so don't know what the issue is. I thought maybe the space in the path causes issues, but building exes works fine.

Please advise!
J.

jvierra
Posts: 14437
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Can't build MSI

Post by jvierra »

The correct path to the OneDrive folder is: "c:\users\<yourid>/OneDrive".
Annotation 2020-04-06 111119.png
Annotation 2020-04-06 111119.png (17.12 KiB) Viewed 692 times

User avatar
stevens
Posts: 416
Joined: Wed Jun 15, 2016 2:26 am

Re: Can't build MSI

Post by stevens »

Thanks, but is that related to the issue?
I moved the location of OneDrive to (actually it is D:) D:\My OneDrive\ and the creation of the exe works fine, everything else also.
So why would the msi have issues with it? Is there somewhere where I can find logs what is happening/why it isn't doing anything, the msi creation?

jvierra
Posts: 14437
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Can't build MSI

Post by jvierra »

It is unclear where you are building the MSI. The MSI build displays a log in the console. It will tell you where it built the MSI.

I also suggest reading the blog articles on using the installer and related items.

If that doesn't help then I recommend posting in the support forum for PSS and a Sapien person will work with you to resolve this.

User avatar
stevens
Posts: 416
Joined: Wed Jun 15, 2016 2:26 am

Re: Can't build MSI

Post by stevens »

The MSI build didn't show anything at all, it just not started at all. Nothing happened.
Found out that a script added to the msi had a wrong path, msi is building fine again. Though it would be good to get some kind of indication when building the msi what is wrong.

User avatar
Alexander Riedel
Posts: 7376
Joined: Tue May 29, 2007 4:43 pm

Re: Can't build MSI

Post by Alexander Riedel »

Usually PSBuild reports exactly which file is missing. We moved files to OneDrive, tried with mapped drive letters and without. We always received an error message explaining which file was absent.
Please post in a product support forum with version details and attach your .psbuild file.
Alexander Riedel
SAPIEN Technologies, Inc.

Locked