ListView subitems not showing in Tile view

Ask questions about creating Graphical User Interfaces (GUI) in PowerShell and using WinForms controls.
Forum rules
Do not post any licensing information in this forum.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
MDinice
Posts: 20
Joined: Sat Apr 30, 2016 10:53 am

ListView subitems not showing in Tile view

Post by MDinice » Sun Apr 15, 2018 10:06 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio 2018 v5.5.150
32 or 64 bit version of product: 64 bit
Operating system: Win 10
32 or 64 bit OS: 64 bit

*** Please add details and screenshots as needed below. ***
ListView sub items don't seem to be showing in Tile view. sample form attached
DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM
Attachments
frmLvToolbox.psf
(58.2 KiB) Downloaded 17 times

User avatar
Alexander Riedel
Posts: 6642
Joined: Tue May 29, 2007 4:43 pm

Re: ListView subitems not showing in Tile view

Post by Alexander Riedel » Sun Apr 15, 2018 11:51 am

[Topic moved by moderator]
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
jvierra
Posts: 12673
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: ListView subitems not showing in Tile view

Post by jvierra » Sun Apr 15, 2018 12:11 pm

It appears you may have posted the wrong form as this form has no data and appears to have a random array of panels and other controls.

Post just a simple ListView showing the issue you wish help with.

Attached is an example of some of the ways to use a ListView
Attachments
Demo-ListViewIcons.psf
(18.28 KiB) Downloaded 19 times

User avatar
MDinice
Posts: 20
Joined: Sat Apr 30, 2016 10:53 am

Re: ListView subitems not showing in Tile view

Post by MDinice » Tue Apr 17, 2018 6:12 pm

sorry about that this should have items and sub-items
Attachments
frmLvToolbox.psf
(57.41 KiB) Downloaded 19 times

User avatar
jvierra
Posts: 12673
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: ListView subitems not showing in Tile view

Post by jvierra » Tue Apr 17, 2018 6:18 pm

No code and it does not clear up what you are asking. What is the question?

User avatar
MDinice
Posts: 20
Joined: Sat Apr 30, 2016 10:53 am

Re: ListView subitems not showing in Tile view

Post by MDinice » Tue Apr 17, 2018 6:32 pm

Are the items showing in the listview when you run the form? the items were built with the groups and items collection in the right panel in design mode. so there is no extra code and their shouldn't have to be. each item in the items collection has a single sub item that should be but is not showing. I would think those sub items should also be showing in design view.

Capture.PNG
Capture.PNG (84.14 KiB) Viewed 419 times

User avatar
jvierra
Posts: 12673
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: ListView subitems not showing in Tile view

Post by jvierra » Tue Apr 17, 2018 7:05 pm

The form you posted has NO code at all. It is just a form with a control.
Defining groups and items does not create a list. It just creates the template.

User avatar
jvierra
Posts: 12673
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: ListView subitems not showing in Tile view

Post by jvierra » Tue Apr 17, 2018 7:27 pm

Without columns you will not see subitems. In "Tile" view you will not see subitems. Add columns and switch to detail view to see all items and subitems.
Attachments
frmLvToolbox (1).psf
(64.24 KiB) Downloaded 18 times

User avatar
MDinice
Posts: 20
Joined: Sat Apr 30, 2016 10:53 am

Re: ListView subitems not showing in Tile view

Post by MDinice » Tue Apr 17, 2018 7:46 pm

Unfortunately i'm not looking to use detail view. i'm trying to make grouped buttons for a lack of a better description. and this right out of Sapiens spotlight on the list view
Capture2.PNG
Capture2.PNG (36.24 KiB) Viewed 405 times
It also states later on that if more then one sub-item exists only the first in the collection will display this is why each item only has one sub-item. As you can see in my initial screen shot the large image and main item show this is why I was reporting the first sub-item not showing as a possible bug. I reported a treeview bug a month or so back that they acknowledged and fixed so I thought this might also be an issue. That is also why i posted in the powershell studio forum and not the gui. The article mentions the value being ignored in OS's earlier then XP so I was assuming it would work in OS's later then XP. If that is a wrong assumption I apologize. I do appreciate and am grateful for the quick responses.

User avatar
jvierra
Posts: 12673
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: ListView subitems not showing in Tile view

Post by jvierra » Tue Apr 17, 2018 8:46 pm

The ListView is a very unmanageable control and I do not have any examples that do what you want. The behavior of the control is also very flakey if you mix different modes.

Tomorrow I will try to put together an example that may be helpful. I, personally, avoid the control because it seldom does what I need. Using a ListView as a menu can be done but it will not work as expected. As soon as you deviate from any example it will change modes and leave you confused.

Locked