Support Forums

Greetings from Cajun land

Batch, ASP, JScript, Kixtart, etc.
Forum rules
Do not post any licensing information in this forum.
User avatar
nsaska
Posts: 5
Joined: Thu Jan 16, 2014 12:16 pm

Greetings from Cajun land

Postby nsaska » Tue Jul 01, 2014 11:05 am

Newbie to batch scripting and power shell so I was asked to join your community to further develop my self :D I'm self thought and paying for it all my self. Live and work in Frierson, Louisiana and working for a mid size Oil & Gas companies IT dept. Looking to better and further develop my self since the normal IT HelpDesk title will soon disappear.

Task at hand, I'm looking to create a script to do a silent install an exe file but USSF is not able to help since it's C++ wrapped. Error: The header returned by PEiD was 'Nothing found [Overlay]'

Some general guidance would be greatly be appreciated. I've created some other scripts which worked like a charm but those were MSI packages so this is my first go around with exe type.

Cheers
NS
User avatar
jvierra
Posts: 9717
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Greetings from Cajun land

Postby jvierra » Tue Jul 01, 2014 11:26 am

Hi - welcome to ScriptingAnswers.

Unfortunately C++ is not PowerShell or any other scripting language.

If you are writing installer code you will need to post questions in a developer forum for the development tools you are using.

MSI is not a script. It is an installer file/database. We do not support MSI here either.
User avatar
nsaska
Posts: 5
Joined: Thu Jan 16, 2014 12:16 pm

Re: Greetings from Cajun land

Postby nsaska » Tue Jul 01, 2014 11:52 am

may have worded things wrong I think. I'm looking for help with a batch script. Right or wrong section?
User avatar
jvierra
Posts: 9717
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Greetings from Cajun land

Postby jvierra » Tue Jul 01, 2014 12:10 pm

Can you post the batch script with a specific question. What is wrong? What errors are you getting? Please describe your issue.
User avatar
nsaska
Posts: 5
Joined: Thu Jan 16, 2014 12:16 pm

Re: Greetings from Cajun land

Postby nsaska » Tue Jul 01, 2014 2:03 pm

:: Set script parent directory:
SET _ScriptDir=%~dp0
SET _ScriptDir=%_ScriptDir:~0,-1%

:: Display status message:
ECHO.
ECHO Installing Warrior now...

:: Run commands:
START "Install" /WAIT "%_ScriptDir%\SRC\x86\setup_ch_V7_2013_10_02001" /QUIET /RESTART

:: Display return code and set exit code:
ECHO. & ECHO Return Code: %ERRORLEVEL% & SET "_EXITCODE=%ERRORLEVEL%"

:: Display completion notice:
ECHO.
ECHO Done!

:: Delay for processing:
PING 127.0.0.1 -n 3 > NUL

:: Pause to view results:
:: ECHO.
:: PAUSE
EXIT %_EXITCODE%


installation starts, then closes with error code -1073740791
User avatar
jvierra
Posts: 9717
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Greetings from Cajun land

Postby jvierra » Tue Jul 01, 2014 2:54 pm

This is not a scripting issue. It is an issue with the installer. Consult the b==vendor as the code is vendor specific and is reported with Oracle and JRE.
User avatar
nsaska
Posts: 5
Joined: Thu Jan 16, 2014 12:16 pm

Re: Greetings from Cajun land

Postby nsaska » Wed Jul 02, 2014 11:41 am

may I ask how you knew that?
User avatar
jvierra
Posts: 9717
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Greetings from Cajun land

Postby jvierra » Wed Jul 02, 2014 11:48 am

A batch file cannot generate that error. If you look up the error you will see that Oracle products regularly gen that error because of missing prerequisites.
User avatar
nsaska
Posts: 5
Joined: Thu Jan 16, 2014 12:16 pm

Re: Greetings from Cajun land

Postby nsaska » Thu Jul 03, 2014 6:39 am

how would I enable Install logging in my script? would that help me? I've emailed the Vendor and he stated:

That error code (Access Violation 0xC0000005) is coming back from InstallShield so I asked them about it. I will let you know if I hear anything.
User avatar
jvierra
Posts: 9717
Joined: Tue May 22, 2007 9:57 am
Contact:

Re: Greetings from Cajun land

Postby jvierra » Thu Jul 03, 2014 6:47 am

nsaska wrote:how would I enable Install logging in my script? would that help me? I've emailed the Vendor and he stated:

That error code (Access Violation 0xC0000005) is coming back from InstallShield so I asked them about it. I will let you know if I hear anything.


Again you are asking a question about a custom installer and not about a script. You need to ask the vendor these questions as they are the ones who created the installer package.

Return to “Other Scripting Languages”

Who is online

Users browsing this forum: No registered users and 1 guest

cron