Issues with elevation after 1803 upgrade

Ask your PowerShell-related questions, including questions on cmdlet development!
Forum rules
Do not post any licensing information in this forum.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
Locked
weslein
Posts: 7
Joined: Sun Jul 12, 2020 8:53 am

Issues with elevation after 1803 upgrade

Post by weslein »

So my company has a lot of remote users, and to get them upgraded to 1803 and update firmware we send them thumbdrives that have a script on it that they run. I built it via Powershell Studio so I could bake the admin credentials into it without fear of someone being able to view said credentials and on a machine already running 1703 it works great. However, if it is run on one that is already running 1803 it gets an "Access is denied" error when trying to create the scheduled task that runs the firmware upgrade after rebooting. I know I read some places that 1803 disable or messed with the built-in admin account, but this is running with one we added via GPO when the machine is imaged. If I right-click the exe and "Run as administrator" it works fine, but if I rely on the exe to self-elevate with the baked-in credentials it doesn't work.

Has anyone seen anything like that?

Thanks
Last edited by weslein on Mon Jul 13, 2020 6:44 am, edited 1 time in total.

jvierra
Posts: 14691
Joined: Tue May 22, 2007 9:57 am
Answers: 7
Has voted: 2 times
Been upvoted: 5 times

Re: Issues with elevation after 1803 upgrade

Post by jvierra »

You have to specify to run the EXE elevated when you build it. Your issue is likely that UAC has been disabled on the older systems but not on the neer systems. No changes were made to the Admin account. I don't know where you heard that.

weslein
Posts: 7
Joined: Sun Jul 12, 2020 8:53 am

Re: Issues with elevation after 1803 upgrade

Post by weslein »

jvierra wrote:
Sun Jul 12, 2020 10:29 am
You have to specify to run the EXE elevated when you build it. Your issue is likely that UAC has been disabled on the older systems but not on the neer systems. No changes were made to the Admin account. I don't know where you heard that.
Thank you very much.

Locked