Support Forums

iPowerShell Pro needs update

Support forums for users of iPowerShell Pro
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
dchich
Posts: 5
Joined: Fri Feb 17, 2012 4:54 am

iPowerShell Pro needs update

Postby dchich » Fri Feb 17, 2012 4:54 am

While I can not say this for all of the libraries in the iPowerShell Pro iPhone/iPad App, The Exchange Management library is in desperate need of an update.

There are cmdlets from Exchange 2010 SP1 that are missing from the Exchange module, let alone SP2.

I actually purchased the "Pro" version, thinking that the free version i had just was no longer being updated and that the new commands would be in the paid version

In all honesty, there should be separate libraries for each Version of Exchange if not one for each SP...

For example, the "New-MailboxMoveRequest" is not in the App... there is only the "Move-Mailbox" command
User avatar
Alexander Riedel
Posts: 5793
Joined: Tue May 29, 2007 4:43 pm

iPowerShell Pro needs update

Postby Alexander Riedel » Fri Feb 17, 2012 4:59 am

You know you can import any cmdlet help you like, right?
Alexander Riedel
SAPIEN Technologies, Inc.
User avatar
dchich
Posts: 5
Joined: Fri Feb 17, 2012 4:54 am

iPowerShell Pro needs update

Postby dchich » Fri Feb 17, 2012 6:07 am

Yes, I know that I can, but why should i have to?

I paid for the app to use as a reference, so that if i needed to find help on command i wouldn't have to go out to technet and research it there... Or try to go through the help in the PS console...

i don't think its really too much to ask for Sapien to update the app with the current command sets.

If I knew it was on me to keep it updated, i wouldn't have bought the app, and just copied all of the help files into a OneNote notebook.

User avatar
Ferdinand Rios
Posts: 358
Joined: Tue Nov 14, 2006 2:56 am

iPowerShell Pro needs update

Postby Ferdinand Rios » Fri Feb 17, 2012 7:11 am

I will look into getting the most current lib on there next week. But the one of the reasons we made the product user updatable was so that when new libs are released (which is out of our control) users can update them on their schedule.
F.G. Rios
User avatar
dchich
Posts: 5
Joined: Fri Feb 17, 2012 4:54 am

iPowerShell Pro needs update

Postby dchich » Fri Feb 17, 2012 7:44 am

That would be great...

I think the fact that the product is user update-able is absolutely fantastic... But I think its fantastic for the ability to enter custom aliases and to include 3rd party libraries...

I would expect big updates (like new releases, and Service packs for core MS components like Exchange AD and SQL) to be part of regular product updates.

Thanks
User avatar
dchich
Posts: 5
Joined: Fri Feb 17, 2012 4:54 am

iPowerShell Pro needs update

Postby dchich » Tue Apr 03, 2012 2:49 am

Any idea on when or if the libraries are going to be updated? It's been over a month and a half since the above posts, and no updates.
User avatar
Ferdinand Rios
Posts: 358
Joined: Tue Nov 14, 2006 2:56 am

iPowerShell Pro needs update

Postby Ferdinand Rios » Tue Apr 03, 2012 3:09 am

We are working with Microsoft to get access to the new libs, but they are "looking into it." As soon as I have access to the libs, they will be posted.
F.G. Rios
User avatar
Ferdinand Rios
Posts: 358
Joined: Tue Nov 14, 2006 2:56 am

iPowerShell Pro needs update

Postby Ferdinand Rios » Thu Apr 05, 2012 6:59 am

This has been updated. When you are notified of a new version of the app (2.2.112) download it. Then use the RELOAD button on the cmdlets page and download the cmdlets. This will install the Exchange 2010 cmdlets.
F.G. Rios
User avatar
dchich
Posts: 5
Joined: Fri Feb 17, 2012 4:54 am

iPowerShell Pro needs update

Postby dchich » Thu Apr 12, 2012 6:48 am

Awesome, Looks great... I didnt even have to wait for 2.2.112 i just downloaded on 2.2.111 and the command libraries were updated.
Thanks for the help.
As a suggestion, in future updates, you may want to have some sort of compatibility key or the ability to choose versions...

So for example, with to move a mailbox with Exchange 2007 you would use Move-Mailbox while in the 2010 you would use New-MoveRequest. Both commands are in the app, but there is no indication as to which version each works with.

The best way to do it would probably be to list the libraries separately by version.

Anyway, thanks again.
User avatar
Ferdinand Rios
Posts: 358
Joined: Tue Nov 14, 2006 2:56 am

iPowerShell Pro needs update

Postby Ferdinand Rios » Thu Apr 12, 2012 7:06 am

The reason i suggested waiting for 2.2.112 is that I know one cmdlet will crash when selected in version 2.2.111. its the Connect-ExchangeServer cmdlet.
F.G. Rios

Return to “iPowerShell Pro”

Who is online

Users browsing this forum: No registered users and 1 guest