Missing Data

Support forums for users of iPowerShell
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.
User avatar
Rlyon9
Posts: 3
Joined: Wed Feb 08, 2017 5:44 am

Missing Data

Post by Rlyon9 » Wed Feb 08, 2017 5:53 am

Product and version: Ipowershell 5.0.142
OS version: IOS (latest)

If I do a search for get-childitem under cmdlets, it only shows for the security store locations. If I scroll over to the Related Links area, and click on Get-Item, or any of the other links there, it returns a "Alert! Link not found" message. I've tried downloading data, deleting the app and reinstalling it, etc, but no dice.

User avatar
Ferdinand Rios
Posts: 369
Joined: Tue Nov 14, 2006 2:56 am

Re: Missing Data

Post by Ferdinand Rios » Wed Feb 08, 2017 10:10 am

We are in the process of investigating this issue. Thank you for the heads up. We will get this fixed ASAP. I will post here when the fix has occurred and then you can re download the fixed data.
F.G. Rios

User avatar
Ferdinand Rios
Posts: 369
Joined: Tue Nov 14, 2006 2:56 am

Re: Missing Data

Post by Ferdinand Rios » Mon Feb 27, 2017 10:27 am

This bug has been fixed and will be available shortly (as soon as Apple approves the build on the app store.)
IMPORTANT!

You must delete the existing app before you install; the new version. This will make sure any corrupt data files on the device are removed. You will get a new set of data files when you do the download.

Thank you for your patience.
F.G. Rios

User avatar
Rlyon9
Posts: 3
Joined: Wed Feb 08, 2017 5:44 am

Re: Missing Data

Post by Rlyon9 » Thu Mar 02, 2017 8:36 am

Yes, Thank You for this fix! Ipowershell is an important part of my study when I'm stuck in a public spot. However, for some items, (like Get-childitem) if you go to related links, that area is empty.

Thank you!

Richard Lyon

User avatar
Ferdinand Rios
Posts: 369
Joined: Tue Nov 14, 2006 2:56 am

Re: Missing Data

Post by Ferdinand Rios » Thu Mar 02, 2017 9:36 am

I will look into that.

Thank you
F.G. Rios

User avatar
Ferdinand Rios
Posts: 369
Joined: Tue Nov 14, 2006 2:56 am

Re: Missing Data

Post by Ferdinand Rios » Fri Mar 03, 2017 9:08 am

We have identified the problem as improperly constructed xml files from Microsoft. We have made changes to our XSL files to better handle these improperly constructed files. We have just submitted build .144 to the Apple Store with these changes. When that becomes available, please install it.
F.G. Rios