PrimalSQL 2011 and Oracle 10g

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
jjdynamite
Posts: 41
Joined: Tue May 19, 2009 12:31 am

PrimalSQL 2011 and Oracle 10g

Post by jjdynamite » Tue Jun 21, 2011 5:49 am

PrimalSQL 2011 locks up when connecting to a large Oracle Database. I am unable to give any other information as the screen just locks and goes no further. I end up "killing" the process. The same issue existed in the previous version of PrimalSQL when released but was corrected in a later release.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

PrimalSQL 2011 and Oracle 10g

Post by davidc » Tue Jun 21, 2011 6:24 am

Is the program using CPU cycles when it locks up? What steps are you taking then result in the lockup? Does the Database Browser display any information?Please specify the OS and connection type, OLEDB or are you using the Oracle provider? Thank you, David
David
SAPIEN Technologies, Inc.

User avatar
jjdynamite
Posts: 41
Joined: Tue May 19, 2009 12:31 am

PrimalSQL 2011 and Oracle 10g

Post by jjdynamite » Tue Jun 21, 2011 6:53 am

Is the program using CPU cycles when it locks up?
It remains at 100% utilization during lock up. PrimalScript 2011 will connect to the database after 5 minutes of waiting but crashes on the run of the SQL Statment. The statement worked in previous versions as with PrimalSQL.

What steps are you taking then result in the lockup?
Trying to connect to the Oracle database (It is not ready after 30 minutes of waiting).

Does the Database Browser display any information?
No, it only displays the database in its disconnected state.


Please specify the OS and connection type, OLEDB or are you using the Oracle provider?
OS: Windows 7 Enterprise x64
Connection: These all have been tried: OLEDB (Microsoft), ODBC (Data Source) and using the Oracle provider. All have the same result.

The connection does work with Crystal Reports and VS2010.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

PrimalSQL 2011 and Oracle 10g

Post by davidc » Tue Jun 21, 2011 8:26 am

Can you open a new SQL Text Only Document and then try to connect? I will need to look into it further, but my guess it is slowing down when trying to construct the schema and cache. David
David
SAPIEN Technologies, Inc.

User avatar
jjdynamite
Posts: 41
Joined: Tue May 19, 2009 12:31 am

PrimalSQL 2011 and Oracle 10g

Post by jjdynamite » Tue Jun 21, 2011 8:28 am

I only use the SQL Text Document. The Query Document is too slow and most of my queries are too advanced for it.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

PrimalSQL 2011 and Oracle 10g

Post by davidc » Tue Jun 21, 2011 11:15 am

I sent you an email about sending you a test. David
David
SAPIEN Technologies, Inc.

User avatar
jjdynamite
Posts: 41
Joined: Tue May 19, 2009 12:31 am

PrimalSQL 2011 and Oracle 10g

Post by jjdynamite » Tue Dec 13, 2011 1:34 am

Will this be corrected with any of the above providers. The workaround is starting to have issues.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

PrimalSQL 2011 and Oracle 10g

Post by davidc » Tue Dec 13, 2011 5:02 am

Please post a new message with the full details. Thank you, David
David
SAPIEN Technologies, Inc.