Page 1 of 2

Packaged randomly builds non working executables

Posted: Tue Feb 21, 2012 10:33 pm
by tjirsch
As of the latest versions of Primalforms the packager randomly builds non working executables.Starting with a working script/Project, it somtimes works after packaging, sometimes it does not.The error is not in the code, simply retrying to package (4-10) times works eventually,restarting Primalforms and repackagings helps.The error shows when trying to start the packaged application, Windows (7, 64bit, Server 2008 64bit) says: "Ther is a problem with the application, blabla" This is simply annoying. Furthermore, the signing of the executable stopped working completely, PF says "An exception occurred while signing the fileERROR: Unable to sign executable file" Nothing changed, exept the installed PF version.

Packaged randomly builds non working executables

Posted: Wed Feb 22, 2012 3:44 am
by davidc
What version of PrimalForms are you using? David

Packaged randomly builds non working executables

Posted: Wed Feb 22, 2012 5:45 pm
by tjirsch
Version 2.0.20. Problems started about some minor builds earlier, the "unable to sign" error is new to version 2.0.20. The faulty executable problem is not specific to a project, even unchanged project sometimes do not run after repackaging.

Packaged randomly builds non working executables

Posted: Wed Feb 22, 2012 6:33 pm
by Alexander Riedel
Please zip and email one of these faulty executables to support@sapien.com

Packaged randomly builds non working executables

Posted: Thu Feb 23, 2012 4:35 am
by Alexander Riedel
Do you get any error messages when a non-working executable is produced? Are you packaging on a network drive or a local disk?

Packaged randomly builds non working executables

Posted: Thu Mar 08, 2012 6:56 pm
by tjirsch
Everything looks normal, there are no error messages.The Project dir is on a network drive.

Packaged randomly builds non working executables

Posted: Thu Mar 08, 2012 7:10 pm
by tjirsch
NB: Signing works perfectly with primalscript using the same certificate, both signing the script itself or the executable after packaging

Packaged randomly builds non working executables

Posted: Mon Mar 19, 2012 6:52 am
by wlewis
I have been experiencing the same issues with packaging.
(building non-working executables, not cert issues)
This happens on ~4 out of 5 attempts. Retrying (repeatedly) without changing any code or packaging preferences typically works. Same error returned every time.

"Error: Saving updated resources failed: 5"

Possibly related to the export issues where occasionally (most of the time) a new line is not inserted between 2 lines (typically in the "generated form code" region) causing errors when the script runs?

Packaged randomly builds non working executables

Posted: Mon Mar 19, 2012 8:58 am
by Alexander Riedel
Is this on a network or on a local drive?

Packaged randomly builds non working executables

Posted: Mon Mar 19, 2012 9:29 am
by wlewis
All files are stored locally.

On the export issue, it seems to appear most often with datagridview controls.

Code: Select all

$gap_dgv_Results.AutoSizeColumnsMode = 'AllCells' 
$System_Windows_Forms_DataGridViewCellStyle_1 = New-Object 'System.Windows.Forms.DataGridViewCellStyle'     
$System_Windows_Forms_DataGridViewCellStyle_1.Alignment = 'MiddleLeft' 
$System_Windows_Forms_DataGridViewCellStyle_1.BackColor = 'Control'
That same issue (2 lines in 1) with the middle line comes up 3 times for 1 control.wlewis2012-03-19 16:32:54