PowerShell Studio 2016 build problem

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
ddlavi@gmail.com
Posts: 34
Joined: Sat Jun 22, 2013 6:37 am

PowerShell Studio 2016 build problem

Post by ddlavi@gmail.com » Sun Apr 17, 2016 11:30 pm

Product, version and build:5.2.119
32 or 64 bit version of product:64
Operating system:server 2012
32 or 64 bit OS:64
PowerShell Version:3.0

Hey,
Until last month I used the PowerShell Studio 2015 version.
EXE successfully built and these were used by third party applications (for example, those developed in C #).
Since I started using in 2016, third-party software can not read the EXE files successfully.
EXE files that are created in the 2016 version is not created correctly.
Create the EXE files from PowerShell Studio 2015 - the problem does not occur.

You have a fundamental bug.
Please take care of the problem as quickly as possible !

Note: There is also a bug when building the EXE from PowerShell Studio 2016 running on Server 2008 R2.
Thank you,
Didi

User avatar
Alexander Riedel
Posts: 7053
Joined: Tue May 29, 2007 4:43 pm

Re: PowerShell Studio 2016 build problem

Post by Alexander Riedel » Sun Apr 17, 2016 11:48 pm

Sorry, we do not know what "can not read the EXE files successfully" means.
Please indicate exactly what options you use to build an executable file and what the actual nature of the problem is.
Just saying we "have a bug" does not really allow us to look for anything.

Please be specific and provide screenshots, error message or samples if possible.

"Note: There is also a bug when building the EXE from PowerShell Studio 2016 running on Server 2008 R2."
Again, this is not clear. What is the behavior you see? Please remember that when you post in the forum that we cannot see your screen.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
ddlavi@gmail.com
Posts: 34
Joined: Sat Jun 22, 2013 6:37 am

Re: PowerShell Studio 2016 build problem

Post by ddlavi@gmail.com » Mon Apr 18, 2016 2:15 am

As I understand, my problem is causing great excitement.
I repeat the information I get an answer hopefully this time more serious.

I suggest you read well.

Data:
I have script let's name it for this post Y
Making BUILD through 2015 creates an EXE file - let's name it - Y15
Making BUILD through 2016 creates an EXE file - let's name it - Y16
Y15/16 - The BUILD use the PowerShell 3.0 x64 command line

X is an app that have nothing to do with the PowerShell Studio.
This is c# app (GUI) which compiled in .Net framework 4.0

When X call to Y15 (and send it parameters), as follows:
Y15.EXE 0 0 0 1
In this X gets back the data (Y15 return text).

However, when X call to Y16 exactly in the same way:
Y16.EXE 0 0 0 1
X does not get the information back.

An attempt to pinpoint the problem by using try-catch (in Y16) and printing the error to a file, the results is very bothersome:
The file was created but text cannot be written to it.

I understand it is difficult to accept the fact that this is a bug, on the other hand offers you to take what I have presented here very seriously

Thanks,
Didi

User avatar
Alexander Riedel
Posts: 7053
Joined: Tue May 29, 2007 4:43 pm

Re: PowerShell Studio 2016 build problem

Post by Alexander Riedel » Mon Apr 18, 2016 2:39 am

I am not certain why you would think we did not read your original post or what created the impression we would not take this seriously.
We are most certainly taking any reports seriously.

However, once again you provide virtually no information as to what the problem is.

What little I understand from your post is this:

You run an exe created with Powershell Studio some what and pass it parameters.
The output is not what you expect with PowerShell Studio 2016.

(Y15 return text).??? How?
X does not get the information back. ??? How did you expect to get it back?
"An attempt to pinpoint the problem by using try-catch (in Y16) and printing the error to a file, the results is very bothersome:
The file was created but text cannot be written to it."
What does very bothersome mean? You do not know how to write the error to a file? You do not have permission to write?

It is not difficult to accept that there *may* be a bug, but it is difficult to diagnose with no information. Sending me private messages will just cause further delays, as we do not provide support via private messages.

You need to provide some kind of information as to what your script actually does.
How does it try to transport the information back to your calling exe?
Are you absolutely sure you are using the same build options in both cases?
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
ddlavi@gmail.com
Posts: 34
Joined: Sat Jun 22, 2013 6:37 am

Re: PowerShell Studio 2016 build problem

Post by ddlavi@gmail.com » Mon Apr 18, 2016 2:59 am

Forgive me friend,
But I'm impressed that you did not touch important points.
The information you asking irrelevant.

The only thing that is relevant here:
EXE that built with 2016 does not work !!!
And in 2015 working !!!

Something changed in the BUILD process from version 2015 to version 2016.
The issue is complex, so I asked you if you would like to connect and see for yourself.

If you insist, X app sends parameters to Y15 and it creates a script file according to the parameters and put it in a specific folder.

Thanks,
Didi

User avatar
Alexander Riedel
Posts: 7053
Joined: Tue May 29, 2007 4:43 pm

Re: PowerShell Studio 2016 build problem

Post by Alexander Riedel » Mon Apr 18, 2016 4:19 am

I am very sorry, but "not working" is not something anyone of us can diagnose. Nothing has changed in the build process and unless you provide any actual information we cannot help you. I have already explained to you when answering your private message that we do not under any circumstance connect to another computer directly because of security considerations.

It does not matter what you consider irrelevant or not, I have a reason to ask for this information. In order to diagnose your problem we need to be able to replicate your problem. Since you are not willing to even disclose *how* you try to output or return something, we are not able to assist you in this matter.

I will now close this thread. If you reconsider and want to provide some actual information, please feel free to post again.
You will need to provide the actual powershell code that transfers or outputs what you want to return to the calling exe as well as the .psbuild files for your script, both from the 2015 as well as from the 2016 installation.
Alexander Riedel
SAPIEN Technologies, Inc.