what engine settings work with .net 4.6.1

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
dschmidtberger
Posts: 37
Joined: Fri Jan 08, 2016 12:43 pm

what engine settings work with .net 4.6.1

Post by dschmidtberger » Tue Mar 29, 2016 5:06 am

Product, version and build: PowerShell Studio 2015 [REMOVED BY MODERATOR]

32 or 64 bit version of product:
Operating system: Windows 7
32 or 64 bit OS: 64

i have multiple users able to utilize exe's built, and a few folks on freshly imaged machines whom are failing.
the only difference i am seeing is those that work have the .net framework 4 multi-targeting pack installed along with .net framework 4.6.1

my engine settings that i use for everyone else are PowerShell V5 Host (Windws Forms) x64 in STA Mode

those whom only have 4.6.1 installed all experience the exe crashing immediately upon launch.

they receive: A problem caused the program to stop working correctly. Please close the program.
i have found if i go all the way down to powershell v2 host, it does work, but many functions stop working.

User avatar
dschmidtberger
Posts: 37
Joined: Fri Jan 08, 2016 12:43 pm

Re: what engine settings work with .net 4.6.1

Post by dschmidtberger » Tue Mar 29, 2016 8:04 am

well more testing, got my hands on a new machine with only framework 4.6.1 installed
don't seem to have the issues there

are there any reccomendations for trouble-shooting powershell studio build EXE's crashing upon launch?

User avatar
dschmidtberger
Posts: 37
Joined: Fri Jan 08, 2016 12:43 pm

Re: what engine settings work with .net 4.6.1

Post by dschmidtberger » Tue Mar 29, 2016 8:36 am

well never mind, discovered these users were missing a powershell module

would be nice if the exe would actually provide error information when it crashes like this.
or have execution restrictions include required modules

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: what engine settings work with .net 4.6.1

Post by davidc » Tue Mar 29, 2016 10:00 am

If the script crashes it can cause the executable itself to crash and there isn't much that can be done.

I highly recommend validating that all the necessary modules are available within the script itself and popup a message if any are missing. This way you can exit the script gracefully instead of having PowerShell reporting error after error as it tries to call the missing cmdlets.

David
David
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 7017
Joined: Tue May 29, 2007 4:43 pm

Re: what engine settings work with .net 4.6.1

Post by Alexander Riedel » Tue Mar 29, 2016 10:08 am

Please keep in mind that "it is crashing" is not a Windows error message. Please always report the exact error you see. I do not know what you see exactly in this case, but we have seen reports of "crashing" that only had a message box with a missing file :D
So please always include the actual text or a screenshot. Thanks!
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: what engine settings work with .net 4.6.1

Post by davidc » Tue Mar 29, 2016 10:23 am

For your account security, please do not post your subscription number on the forums.
David
SAPIEN Technologies, Inc.