Page 1 of 1

Customized modules not appearing in Powershell Studio

Posted: Thu Jan 21, 2016 12:15 am
by weiyen.tan@gmail.com
Product, version and build: PowerShell Studio 2015 v4.2.99
32 or 64 bit version of product: 64 Bit
Operating system: Windows 10 Enterprise
32 or 64 bit OS: 64 bit

Hi,

I have a few powershell modules that I have created and stored in the default
c:\Program Files\WindowsPowershell\Modules

I can see it in the shell and get the help in functions by using get-help and .

What I would like is to be able to see that in the objectbrowser in powershell studio. I can't make it see my customised module.

What do I need to do to make my customised modules appear in Powershell studio?

Re: Customized modules not appearing in Powershell Studio

Posted: Thu Jan 21, 2016 9:09 am
by davidc
If the module doesn't appear in the Object browser, you will have to refresh PowerShell Studio's cache:
Rebuild Cache.png
Rebuild Cache.png (14.18 KiB) Viewed 1389 times
Since some modules are version / Platform specific, please verify your platform settings in PowerShell Studio.

David

Re: Customized modules not appearing in Powershell Studio

Posted: Sun Jan 31, 2016 3:32 am
by weiyen.tan@gmail.com
Hi David,

Just a follow up with this.

I managed to fix the problem after scouring your old forum posts. I found this.

I had to do a clean and then a rebuild for the 64 bit version. Everything is working as is...perhaps this is something that needs to be investigated. As it does not seem to be initiating when pressing the rebuild cache button .