4.2.91 - Packager Build not working

Support for all customers who have purchased a SAPIEN PowerShell Studio product license. This forum does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
bmclain
Posts: 39
Joined: Mon Oct 22, 2007 1:47 am

4.2.91 - Packager Build not working

Post by bmclain » Thu Aug 13, 2015 8:08 am

Just installed the new update. I can no longer package my script. I've tried switching the Platform, but still doesn't create the .exe file. Here is the output displayed:

>> Package 'C:\SVN\repos\Implementation\Users\cerbdm\FEAudit\FEAudit_Project\FEAudit.psproj'
SAPIEN Package and Deploy Tool 4.0 (c) 2005 - 2015 SAPIEN Technologies, Inc.

Adding C:\SVN\repos\Implementation\Users\cerbdm\FEAudit\FEAudit_Project\FEAudit.Package.ps1
Writing scripts to FEAudit.exe
Embedding default manifest...
Package completed


>> Completed

User avatar
SAPIEN Support Forums
Posts: 945
Joined: Wed Dec 03, 2014 2:26 pm

4.2.91 - Packager Build not working

Post by SAPIEN Support Forums » Thu Aug 13, 2015 8:08 am

This is an automated post. A real person will respond soon.

Thank you for posting, bmclain.

Did you remember to include the following?
  • 1. Product, version and build (e.g. Product: PowerShell Studio 2014, Version & Build: 4.1.71. Version and build information can be found in the product's About box accessed by clicking the blue icon with the 'i' in the upper right hand corner of the ribbon.)
    2. Specify if you are running a 32 or 64 bit version
    3. Specify your operating system and if it is 32 or 64 bit.
    4. Attach a screenshot if your issue can be seen on the screen
    5. Attach a zip file if you have multiple files (crash reports, log entries, etc.) related to your issue.
If not, please take a moment to edit your original post or reply to this one.

*** Make sure you do not post any licensing information ***

User avatar
davidc
Posts: 5889
Joined: Thu Aug 18, 2011 4:56 am

Re: 4.2.91 - Packager Build not working

Post by davidc » Thu Aug 13, 2015 9:10 am

What settings are you using?

It could be that something is preventing the exe from writing. This could be antivirus, permission issue or even a locked file.

Do you see a packagername.exe.intermediate file?

Try deleting all packager related files such as the intermediate and any config file.

David
David
SAPIEN Technologies, Inc.

User avatar
bmclain
Posts: 39
Joined: Mon Oct 22, 2007 1:47 am

Re: 4.2.91 - Packager Build not working

Post by bmclain » Thu Aug 13, 2015 9:22 am

Platform: SAPIEN PowerShell V2 Host (Windows) x64. STA Mode checked. I deleted the config file and now I'm getting this error:
>> Package 'C:\SVN\repos\Implementation\Users\cerbdm\FEAudit\FEAudit_Project\FEAudit.psproj'
Error: The directory name is invalid
>> Completed

I have that file, and here is the contents of it:

<Project>
<Version>1</Version>
<FileID>31448512-0c87-4c42-bdbc-21d9b761b7f2</FileID>
<ProjectType>0</ProjectType>
<Files>
<File ReferenceName="" Build="0">Startup.pss</File>
<File ReferenceName="Call-Global_ps1" Build="0" CommandExtension="True">Globals.ps1</File>
<File ReferenceName="Call-FEAudit_psf" Build="0">FEAudit.psf</File>
<File ReferenceName="Call-EmailForm_psf" Build="0">EmailForm.psf</File>
<File ReferenceName="Call-Help_Dialog_psf" Build="0">Help Dialog.psf</File>
</Files>
</Project>

All of those files exist.

User avatar
bmclain
Posts: 39
Joined: Mon Oct 22, 2007 1:47 am

Re: 4.2.91 - Packager Build not working

Post by bmclain » Thu Aug 13, 2015 9:24 am

and I don't have an intermediate file

User avatar
davidc
Posts: 5889
Joined: Thu Aug 18, 2011 4:56 am

Re: 4.2.91 - Packager Build not working

Post by davidc » Thu Aug 13, 2015 10:14 am

Did anything else change other then deleting the file?

Where is PowerShell Studio installed?

There should be an executable called PSBuild.exe located in the same folder as PowerShell Studio.exe.

David
David
SAPIEN Technologies, Inc.

User avatar
bmclain
Posts: 39
Joined: Mon Oct 22, 2007 1:47 am

Re: 4.2.91 - Packager Build not working

Post by bmclain » Thu Aug 13, 2015 1:31 pm

Powershell studio is installed to C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015. There is a PSBuild.exe in that same folder.

User avatar
davidc
Posts: 5889
Joined: Thu Aug 18, 2011 4:56 am

Re: 4.2.91 - Packager Build not working

Post by davidc » Thu Aug 13, 2015 2:09 pm

We are still unable to reproduce this. Try moving the location of the Project and if that makes a difference.

If the error continues, please zip and email the project to support@sapien.com so that we can try to reproduce this on our end.

David
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5889
Joined: Thu Aug 18, 2011 4:56 am

Re: 4.2.91 - Packager Build not working

Post by davidc » Mon Aug 24, 2015 9:46 am

We got your files and are able to build the executable without issue.

1. What OS are you running?
2. Do you have another machine you can test this with?

David
David
SAPIEN Technologies, Inc.

User avatar
bmclain
Posts: 39
Joined: Mon Oct 22, 2007 1:47 am

Re: 4.2.91 - Packager Build not working

Post by bmclain » Thu Aug 27, 2015 11:05 am

I'm running Windows 10 - Build 10525. The only other person with a license to test this is still on the version that was working for me. I'm not about to have them upgrade and break our ability to package the script.