PSS2015 not creating executable

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
PGomersall
Posts: 90
Joined: Sun Mar 03, 2013 12:40 pm

PSS2015 not creating executable

Post by PGomersall » Thu Feb 05, 2015 9:25 am

Hi at Sapien,
Just upgraded to PowerShell Studio 2015 v4.2.77. I am running on Windows Server 2012 R2.
1) I open a psf file created in 2014; no issues
2) I check its build settings are correct
3) If I choose either Build or Build and Run the executable is not created (at least not in any expected place).
The output code for 2 examples are below:

>> Package 'D:\PS\PSS\Files\Copy-Items\Copy-Items.psf'
>> Building (Copy-Items.psf) ...
SAPIEN Package and Deploy Tool 4.0 (c) 2005 - 2015 SAPIEN Technologies, Inc.

Adding D:\PS\PSS\Files\Copy-Items\Copy-Items.Package.ps1
Writing scripts to Copy-Items.exe
Embedding default manifest...

>> Completed


>> Package 'D:\PS\PSS\Files\Get-Logons\Get-Logons.psf'
>> Building (Get-Logons.psf) ...
SAPIEN Package and Deploy Tool 4.0 (c) 2005 - 2015 SAPIEN Technologies, Inc.

Adding D:\PS\PSS\Files\Get-Logons\Get-Logons.Package.ps1
Writing scripts to Get-Logons.exe
Embedding default manifest...

>> Completed
Attachments
No-Build.png
No-Build.png (19.98 KiB) Viewed 1913 times
Last edited by PGomersall on Thu Feb 05, 2015 9:26 am, edited 1 time in total.

User avatar
SAPIEN Support Forums
Posts: 945
Joined: Wed Dec 03, 2014 2:26 pm

PSS2015 not creating executable

Post by SAPIEN Support Forums » Thu Feb 05, 2015 9:25 am

This is an automated post. A real person will respond soon.

Thank you for posting, pgomersall.

Did you remember to include the following?
  • 1. Product, version and build (e.g. Product: PowerShell Studio 2014, Version & Build: 4.1.71. Version and build information can be found in the product's About box accessed by clicking the blue icon with the 'i' in the upper right hand corner of the ribbon.)
    2. Specify if you are running a 32 or 64 bit version
    3. Specify your operating system and if it is 32 or 64 bit.
    4. Attach a screenshot if your issue can be seen on the screen
    5. Attach a zip file if you have multiple files (crash reports, log entries, etc.) related to your issue.
If not, please take a moment to edit your original post or reply to this one.

*** Make sure you do not post any licensing information ***

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: PSS2015 not creating executable

Post by davidc » Thu Feb 05, 2015 10:19 am

Also, do you see a file named <packager name>.exe.intermediate in the same folder?

Where <packager name> is the name of the output name you specified in the packager settings.

If this is the case, we are aware of this issue. You should be able to rename the file and it should work.

David
David
SAPIEN Technologies, Inc.

User avatar
PGomersall
Posts: 90
Joined: Sun Mar 03, 2013 12:40 pm

Re: PSS2015 not creating executable

Post by PGomersall » Thu Feb 05, 2015 10:25 am

Yes I do David. I did notice a previous post requesting a link to an older version that mentioned similar problem with PSS after I posted. Doing these steps work.
Thank you.
Pete

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: PSS2015 not creating executable

Post by davidc » Thu Feb 05, 2015 11:48 am

I posted a temporary fix:

http://www.sapien.com/forums/viewtopic. ... 378#p45378

Please try the temp fix until we resolve the issue.

David
David
SAPIEN Technologies, Inc.

User avatar
martytx56
Posts: 21
Joined: Wed Oct 29, 2014 2:29 pm

Re: PSS2015 not creating executable

Post by martytx56 » Fri Feb 06, 2015 5:29 am

I had the same issue and the rename worked fine.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: PSS2015 not creating executable

Post by davidc » Wed Feb 18, 2015 12:10 pm

Please try the latest build 4.2.81 and lets us know if the issue is resolved.

David
David
SAPIEN Technologies, Inc.

User avatar
Cliving
Posts: 57
Joined: Mon Oct 13, 2014 6:23 am

Re: PSS2015 not creating executable

Post by Cliving » Tue Feb 24, 2015 8:14 am

I am unsure if this is relevant, but I didn't want to make another thread while there are already several covering this issue.

I have notices that most times when this happens, it is when I am working from a network location, specifically a DFS Namespace. I tend to keep all my projects on a network share that is a target of a DFS Namespace. There have been times that I don't have time to troubleshoot the .exe not being fully created issue when I have to get a patch out for one of our tools. What I have done before is save and close the project in PowerShell Studio, copy down the project directory to a local drive on my workstation, open the project from the local copy and build the package. Usually, this fixes the issue for me.

Could it be possible that working on a project from a network location is causing this issue? I just thought I'd bring this up in case it helps the devs resolve this issue.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: PSS2015 not creating executable

Post by davidc » Tue Feb 24, 2015 10:08 am

Always post a new topic even if it is the same issue. Otherwise the thread can get confusing when two people are responding.

David
David
SAPIEN Technologies, Inc.