SAPIEN Package and Deploy Tool Crash

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
lee.wilmott
Posts: 10
Meble kuchenne na zamówienie - na wymiar - Wrocław
Joined: Fri Sep 26, 2014 4:12 am

SAPIEN Package and Deploy Tool Crash

Post by lee.wilmott »

I hope someone can help me.

I have just installed PowerShell Studio 2015 v4.2.76 x64.

I am using Windows 8.1 Enterprise x64.

I opened PowerShell Studio 2015 and opened an existing project. I wanted to create an .exe. So I ran the "Packager\Build". This then crashed and displayed an error.

I uninstalled PowerShell Studio 2015 and ensured that the Program Files\SAPIEN... folder was gone.

I reinstalled PowerShell Studio 2015.

I opened the same project and 'built' it...the crash reoccurred.

I then closed my existing project and created a NEW project and tried to 'build' that too. This too crashed.

[For the purpose of this test] I am running PowerShell Studio while logged on as an administrator equivalence account (with UAC disabled).

I have attached a screenshot of the crash.

Any ideas? Please help!

Lee
Attachments
SAPIEN Package and Deploy Tool Crash ScreenShot.png
SAPIEN Package and Deploy Tool Crash ScreenShot.png (20.87 KiB) Viewed 2760 times

User avatar
SAPIEN Support Forums
Posts: 945
Joined: Wed Dec 03, 2014 2:26 pm

SAPIEN Package and Deploy Tool Crash

Post by SAPIEN Support Forums »

This is an automated post. A real person will respond soon.

Thank you for posting, lee.wilmott.

Did you remember to include the following?
  • 1. Product, version and build (e.g. Product: PowerShell Studio 2014, Version & Build: 4.1.71. Version and build information can be found in the product's About box accessed by clicking the blue icon with the 'i' in the upper right hand corner of the ribbon.)
    2. Specify if you are running a 32 or 64 bit version
    3. Specify your operating system and if it is 32 or 64 bit.
    4. Attach a screenshot if your issue can be seen on the screen
    5. Attach a zip file if you have multiple files (crash reports, log entries, etc.) related to your issue.
If not, please take a moment to edit your original post or reply to this one.

*** Make sure you do not post any licensing information ***

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: SAPIEN Package and Deploy Tool Crash

Post by davidc »

I tested the packager on Windows 8.1 and I wasn't able to reproduce the crash.

1. Does it crash when you create a new file and package it?

2. Do you have the Microsoft C++ 2012 Redistributable installed (x86 and x64)?

3. What settings are you using to package the project?

Note: In Windows 8.1, you still have to use "Run as Administrator" to give the application full admin access.

David
David
SAPIEN Technologies, Inc.

User avatar
lee.wilmott
Posts: 10
Joined: Fri Sep 26, 2014 4:12 am

Re: SAPIEN Package and Deploy Tool Crash

Post by lee.wilmott »

Hi David,

Many thanks for your reply.

1. Yes, it does crash when I create a new "Form Project" and package it. I create a "New Form Project"...make NO changes...make NO changes to the Packager settings. Press "Build" and it crashes.

2. I can confirm that the x86 'and' the x64 Microsoft C++ 2012 Redistributable software is installed.

3. I have not changed the default Packager settings at all...So I assume they are default. But I've listed them anyway...

- Platform: SAPIEN PowerShell V3 Host (Command line) x64
- Icon File: C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015\ScriptPackage.ico
- No Execution Restrictions

Furthermore...

a) An "Empty Project" a "Multi Form Project" and a "Form Project" all result in 'crashes' when I press "Build".

b) Since the above tests, I have changed the Build Settings and changed the "Platform"...it doesn't matter what I select it still crashes.

c) For what it's worth...I used PowerShell Studio 2014 (v4.1.74) (on the same workstation) without issue.

Please, please help.

Lee

User avatar
lee.wilmott
Posts: 10
Joined: Fri Sep 26, 2014 4:12 am

Re: SAPIEN Package and Deploy Tool Crash

Post by lee.wilmott »

I have noticed that PowerShell Studio 2015 v4.2.77 has been released. I have now installed v4.2.77 (upgraded from v4.2.76) and the same crash problem exists.

:-(

Lee

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: SAPIEN Package and Deploy Tool Crash

Post by davidc »

Can you post any Window Event log entries pertaining to PSBuild.exe?

David
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: SAPIEN Package and Deploy Tool Crash

Post by davidc »

Also, do you see a file named <packager name>.exe.intermediate in the same folder? Where <packager name> is the name of the output name you specified in the packager settings.

David
David
SAPIEN Technologies, Inc.

User avatar
lee.wilmott
Posts: 10
Joined: Fri Sep 26, 2014 4:12 am

Re: SAPIEN Package and Deploy Tool Crash

Post by lee.wilmott »

Hi David,

I have just created a Multiform Project and pressed "Build". I can confirm that a file named <packager name>.exe.intermediate exists. Please find attached a copy of the EventLog that mentions PSBuild and also a screenshot of the files that exist after I pressed "Build".

Kind regards,

Lee
Attachments
PSBuild.zip
(8.27 KiB) Downloaded 81 times
2015-02-05 18_03_34-MultiFormProject1800.png
2015-02-05 18_03_34-MultiFormProject1800.png (17.08 KiB) Viewed 2731 times

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: SAPIEN Package and Deploy Tool Crash

Post by davidc »

Here is a temporary fix until we resolve the issue.

I attached the old engines Please replace the following files:

C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015\PSBuild.exe
C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015\ScriptEngines

with the ones provided in the zip file.

Use PSBuildX64.zip if you have the 64bit version of PowerShell Studio install.

Note: This issue doesn't seem to affect Windows 7.

David
Attachments
PSBuildx86.zip
Use if you have the 32-Bit version installed.
(531.14 KiB) Downloaded 85 times
PSBuildx64.zip
Use if you have the 64-Bit version installed.
(536.39 KiB) Downloaded 177 times
David
SAPIEN Technologies, Inc.

User avatar
lee.wilmott
Posts: 10
Joined: Fri Sep 26, 2014 4:12 am

Re: SAPIEN Package and Deploy Tool Crash

Post by lee.wilmott »

Hi David,

The old/previous engines work without issue. Thank you!

Do I assume, therefore, that you have managed to replicate my issue?

Many thanks for your help...I will keep an eye on this thread for a [permanent] fix.

Just one 'small' comment. You said...
I attached the old engines. Please replace the following files:

C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015\PSBuild.exe
C:\Program Files\SAPIEN Technologies, Inc\PrimalScript 2015\ScriptEngines
To assist others I assume you meant...
I attached the old engines. Please replace the following files:

C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015\PSBuild.exe
C:\Program Files\SAPIEN Technologies, Inc\PowerShell Studio 2015\ScriptEngines
Kind regards,

Lee