[PSS 2014][Bug] Slight editor error

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
Bosparan
Posts: 282
Joined: Sun Mar 03, 2013 12:45 pm

[PSS 2014][Bug] Slight editor error

Post by Bosparan » Thu Mar 27, 2014 2:05 am

Hi Sapien Team,

been exploring the new Powershell Studio 2014 and I'm ... well not quite amazed, but something fairly close to it. Definitely above merely happy with the upgrade. Also thanks for implementing so many features I wanted or should have wanted, had I thought of it in the first place. Buuut, with so many new things, some bugs are just gonna happen, and I found one:

PSS Version: 2014 4.1.49.0 (x64)
OS Version: Windows 7 Professional (x64)
WMF Version: 4

Impact: Slight irritation

Symptom:
Some times, the Editor will write this into the output window (when no script is running):
Powershell Studio 2014 wrote:AddSpanIndicator: The indicator is not allowed to be zero-length. This also may have occurred if you specified a TextRange that is outside the bounds of the document.
Reproducibility:
This error has so far only occured when I open a try statement inside a function, but do not close it. Something like this:
PowerShell Code
Double-click the code block to select all.
function abc
{
	try
	{
		Get-Item ...
}
This does not have any impact on the editor that I can notice, but it's slightly irritating. It doesn't happen always either, only sometimes, when klicking or typing.

Cheers, and keep up the good work,
Bosparan

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: [PSS 2014][Bug] Slight editor error

Post by davidc » Thu Mar 27, 2014 9:40 am

The issue will be resolved in the next service build and you are correct this has no impact on the editor.

David
David
SAPIEN Technologies, Inc.