Script Signing in Packager isn't working but reports no errors.

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
SnapOrders
Posts: 2
Last visit: Wed Jun 16, 2021 8:16 am

Script Signing in Packager isn't working but reports no errors.

Post by SnapOrders »

Product, version and build: PowerShell Studio 2021 version 5.8.191
Operating system: Windows 10 build 20H2
PowerShell version(s): 5.1 and PowerShell 7

*** Please add details and screenshots as needed below. ***

It appears that the Packager is no longer signing EXE packages correctly. When building the package, no error is reported. It appears that the package is being signed based on the console output but reviewing the file afterwards shows that it is unsigned. I am able to sign a .ps1 file outside of the Packager without issue.

Packager Output:
packager output.PNG
packager output.PNG (11.39 KiB) Viewed 4826 times
I have included the .ps1 source file and the .psbuild file as an attachment.

Any assistance is appreciated.
Attachments
testsigning.ps1.psbuild
(3.05 KiB) Downloaded 64 times
testsigning.ps1
(1.82 KiB) Downloaded 53 times

User avatar
brittneyr
Site Admin
Posts: 818
Last visit: Fri Jul 30, 2021 12:06 pm
Answers: 16
Been upvoted: 13 times

Re: Script Signing in Packager isn't working but reports no errors.

Post by brittneyr »

We are looking into this and will get back to you soon.
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
Alexander Riedel
Posts: 7719
Last visit: Sat Jul 31, 2021 12:28 pm
Answers: 4
Been upvoted: 10 times

Re: Script Signing in Packager isn't working but reports no errors.

Post by Alexander Riedel »

It seems there is an issue with that particular time stamp server.
I have verified that with the time stamp server you specify, no signature is applied with SAPIEN's signature.
Using http://timestamp.globalsign.com/scripts ... ature=sha2 correctly applies the signature and timestamps it.
Alexander Riedel
SAPIEN Technologies, Inc.

SnapOrders
Posts: 2
Last visit: Wed Jun 16, 2021 8:16 am

Re: Script Signing in Packager isn't working but reports no errors.

Post by SnapOrders »

Thank you. It appears that resolves the issue.