Templates not appearing in "New Form"

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
jlandria
Posts: 2
Joined: Thu Apr 06, 2017 9:36 am

Templates not appearing in "New Form"

Post by jlandria »

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product: PowerShell Studio 2020 (64 Bit)
Build: v5.7.172
OS: Windows Server 2016 Datacenter (64 Bit)
Build: v10.0.14393.0

*** Please add details and screenshots as needed below. ***

Custom form template that I have been using since 2017 no longer appears as an option in the New Form selection screen. The previous location of "C:\Users\<YOUR USER ID>\AppData\Roaming\SAPIEN\PowerShell Studio 2017\Templates\Forms" no longer exists. I recreated the location and restored the custom template folder and still does not appear.

I tried using the "Create Template" from the file menu and there was no error displayed during the save process but the custom template still does not appear as an option.

User avatar
brittneyr
Site Admin
Posts: 537
Joined: Thu Jun 01, 2017 7:20 am

Re: Templates not appearing in "New Form"

Post by brittneyr »

I have found no issues being able to create a template with build 5.7.172. Some time ago, we removed the year from the folder path so the correct path of user-created templates should be:
C:\Users\[User]\AppData\Roaming\SAPIEN\PowerShell Studio\Templates

Can you find your template in this folder?

Also, the path you specified is from 2017. Did you recently update from 2017 to 2020? If so, what build of 2017 were you using previously?
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
jlandria
Posts: 2
Joined: Thu Apr 06, 2017 9:36 am

Re: Templates not appearing in "New Form"

Post by jlandria »

That path did not exist (with or without year). I had to create it. The only thing in there is my template form folder that I copied in manually.

I updated from 2017 to 2018 (in 2018) and then from 2018 to 2019 (in 2019) and recently from 2019 to 2020.

User avatar
brittneyr
Site Admin
Posts: 537
Joined: Thu Jun 01, 2017 7:20 am

Re: Templates not appearing in "New Form"

Post by brittneyr »

You said you created the path manually. Depending of the template the path can vary like the following:
C:\Users\[User]\AppData\Roaming\SAPIEN\PowerShell Studio\Templates\File Templates\PowerShell\Forms
Also, please check the permissions of this folder since it was created manually.

With your template form, is there a corresponding pstemplate file? Without this, PowerShell Studio will not load in a template.
Brittney Ryn
SAPIEN Technologies, Inc.