Lost CMDLET and Function highlights

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST LICENSE NUMBERS, ACTIVATION KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
owinsloe
Posts: 92
Joined: Tue Jul 10, 2012 10:37 am

Lost CMDLET and Function highlights

Post by owinsloe » Thu Dec 12, 2019 7:00 pm

Product: PowerShell Studio 2019 (64 Bit)
Build: v5.6.170
OS: Windows 10 Enterprise (64 Bit)
Build: v10.0.18363.0

It looks like the switch command has caused the loss of highlighting on lines that follow that are not part of a sub-scriptblock. Anything in a sub-scriptblock after this appear to display fine.

If you place braces around the lines that have lost the highlighting then they display correctly.

This code snippet is part of a function. I have also tried, closing and restarting PSS and cutting & pasting the entire source back into the editor. Neither, corrected the behaviour.

pic1 (good)
pic2.jpg
pic2.jpg (131.1 KiB) Viewed 1765 times
pic2 (bad)
pic1.jpg
pic1.jpg (127.95 KiB) Viewed 1765 times

User avatar
brittneyr
Site Admin
Posts: 306
Joined: Thu Jun 01, 2017 7:20 am

Re: Lost CMDLET and Function highlights

Post by brittneyr » Fri Dec 13, 2019 7:58 am

I have been able to reproduce this behavior and have informed the development team. When I have more information, I'll post here.
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
owinsloe
Posts: 92
Joined: Tue Jul 10, 2012 10:37 am

Re: Lost CMDLET and Function highlights

Post by owinsloe » Sun Dec 15, 2019 12:02 pm

Thank you Mandalorian fan :D

User avatar
brittneyr
Site Admin
Posts: 306
Joined: Thu Jun 01, 2017 7:20 am

Re: Lost CMDLET and Function highlights

Post by brittneyr » Wed Jan 15, 2020 9:56 am

This issue has been fixed and will be in the next service release.
Brittney Ryn
SAPIEN Technologies, Inc.

User avatar
brittneyr
Site Admin
Posts: 306
Joined: Thu Jun 01, 2017 7:20 am

Re: Lost CMDLET and Function highlights

Post by brittneyr » Tue Jan 21, 2020 3:40 pm

Please try build 5.7.172 and let me know if the issue still persists.
Brittney Ryn
SAPIEN Technologies, Inc.