Powershell Studio changing default associations for file extensions

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
missingpiece
Posts: 1
Joined: Fri Jul 19, 2019 2:12 am

Powershell Studio changing default associations for file extensions

Post by missingpiece » Tue Nov 12, 2019 5:10 am

Product, version and build: SAPIEN PowerShell Studio 2019,
32 or 64 bit version of product: 64 bit
Operating system: Windows 2012 R2
32 or 64 bit OS: 64 bit

This week we bought a license for SAPIEN Powershell Studio 2019. We are planning to use this product on a Remote Desktop server.

After the installation of Powershell Studio, the default association for .ps1 files changes to SAPIEN Powershell Studio 2019. There was no option during the installation wizard to disable this option. I would like the default association for .ps1 files to remain default (default Powershell IDE) for all the users.

Is there something I missed during the installation? Or is there another simple way to re-set the application associated with the .ps1 file extension back to the default Powershell IDE?

Any help would be appreciated.
-Luca

User avatar
brittneyr
Site Admin
Posts: 235
Joined: Thu Jun 01, 2017 7:20 am

Re: Powershell Studio changing default associations for file extensions

Post by brittneyr » Tue Nov 12, 2019 9:12 am

Try setting the following environmental variable before installing or upgrading:
  1. $env:SKIP_FILEASSOCIATION = '1'
The installer should see the variable and disable the file association.

Let me know if this works for you.
Brittney Ryn
SAPIEN Technologies, Inc.