Listview not working in designer

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
TheVito
Posts: 11
Joined: Mon Sep 25, 2017 4:27 am

Listview not working in designer

Post by TheVito » Tue Oct 29, 2019 3:47 am

To help you better we need some information from you.

*** Please fill in the fields below. If you leave fields empty or specify 'latest' rather than the actual version your answer will be delayed as we will be forced to ask you for this information. ***

Product, version and build: PowerShell Studio 2019 ( 64 bit ), v5.6.168
32 or 64 bit version of product: 64
Operating system: Windows 10 Pro Version 1903 OS Build 18362.418
32 or 64 bit OS: 64

*** Please add details and screenshots as needed below. ***
The listview control does not show column headers when adding them, gridlines do not show, basically it does not work at all. I created a new form project and added a listview to narrow it down to the simplest example.

if you copy a listview from an existing project and past it into a new project then the control shows all the columns and works. but even adding a new listview to an existing project that has a listview working properly, the new listview just appears as a white box no matter what you do it it with the properties.


DO NOT POST SUBSCRIPTIONS, KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM
Attachments
nocolumns.png
nocolumns.png (10.79 KiB) Viewed 1505 times
nocolumns1.png
nocolumns1.png (112.7 KiB) Viewed 1505 times

User avatar
brittneyr
Site Admin
Posts: 236
Joined: Thu Jun 01, 2017 7:20 am

Re: Listview not working in designer

Post by brittneyr » Tue Oct 29, 2019 8:50 am

Columns are not visible by default in a WinForms listview control. If you wish for columns to be visible in a listview, you need to set the value of the View property to Details.
SPS_PropertiesListViewDetails.png
SPS_PropertiesListViewDetails.png (26.71 KiB) Viewed 1485 times
Brittney Ryn
SAPIEN Technologies, Inc.