Installation hangs at "Extracting files from archive"

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
User avatar
jbudde
Posts: 5
Joined: Mon May 04, 2015 6:38 am

Installation hangs at "Extracting files from archive"

Post by jbudde » Thu Jul 25, 2019 6:53 am

Hello,

I'm making this post to hopefully help others. We have reported this issue to Sapien before, but I see that some older forum posts have gone unanswered so here is the answer!

If you're having trouble installing PowerShell studio, either a fresh install or an update, AND you run redirected profiles (specifically app data) in Windows, you need to make a temporary change to run the install correctly. For us, when the installer hangs, it's at the "Extracting files from archive" step. The process that the installer runs under will consume one CPU core (pegged) for as long as you allow it to. The longest we have let one run is 2 days, never completes. AV software removed, ran as admin on a fresh install of windows it simply does not work.

To correct this, open regedit.exe and navigate to the entry below:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

In "User Shell Folders" locate the AppData key.

If the AppData key's value is anything other than "C:\users\[your user name]\appdata", change it to that value, and re-run the installer.

In our case this works 100% of the time for correcting the issue. Don't forget to set the value back to whatever it was prior when the install is complete, and also keep in mind this change needs to happen every time the product has to update!

We do not have issues with any of the other ~220 apps we run here, this is unique to Sapien products, so something is clearly wrong! It would save us a lot of time if you could please fix this. I hope this post helps someone.

Product, version and build: 5.6.166 07 15 19
32 or 64 bit version of product: 64 bit
Operating system: Windows 7 x64 and Windows 10 Pro
32 or 64 bit OS: 64

User avatar
Alexander Riedel
Posts: 7023
Joined: Tue May 29, 2007 4:43 pm

Re: Installation hangs at "Extracting files from archive"

Post by Alexander Riedel » Thu Jul 25, 2019 7:24 am

Thank you for letting us now. We have no particular requirement on AppData not being redirected, nor do we apply any special settings.
Since this happens in the extracting stage, it's not really anything under our control.
I will forward this to our installer tool vendor and see what they can find out.
A few questions though:
1. You mention PowerShell Studio but also say it is "unique to SAPIEN products". Does that mean you replicated the same behavior with, say, WMI Explorer?
2. Did you by any change ever run an installer with a log? "C:\MyPackage\Setup.exe" /L*V "example.log"
3. Can you tell us what exactly the value is in your AppData key? So we can try to replicate this.
Alexander Riedel
SAPIEN Technologies, Inc.

User avatar
jbudde
Posts: 5
Joined: Mon May 04, 2015 6:38 am

Re: Installation hangs at "Extracting files from archive"

Post by jbudde » Thu Jul 25, 2019 7:46 am

1. I have not replicated this issue with any other product. If you kill the product installation of PS Studio when it hangs, scriptmerge and document explorer are already installed and they seem OK.
2. I did not run it with a log this time, but we have done that per support in the past. Sorry I do not have one available.
3. Our default app data is pointed to a share on a server: \\[servername]\data\Home$\[my user name]\Profile-DoNotDelete\AppData\ Previously we had a different share with a different path and we had the same issue. The only way we have every gotten an install to work is to point that key to local storage.

User avatar
Alexander Riedel
Posts: 7023
Joined: Tue May 29, 2007 4:43 pm

Re: Installation hangs at "Extracting files from archive"

Post by Alexander Riedel » Thu Jul 25, 2019 8:01 am

Ok, thanks. I'll forward that.
Alexander Riedel
SAPIEN Technologies, Inc.