package exe not work \\?\ path

This forum can be browsed by the general public. Posting is limited to current SAPIEN license holders with active maintenance and does not offer a response time guarantee.
Forum rules
DO NOT POST SUBSCRIPTION NUMBERS, LICENSE KEYS OR ANY OTHER LICENSING INFORMATION IN THIS FORUM.
Only the original author and our tech personnel can reply to a topic that is created in this forum. If you find a topic that relates to an issue you are having, please create a new topic and reference the other in your post.

Any code longer than three lines should be added as code using the 'Select Code' dropdown menu or attached as a file.
MIC-23145632
Posts: 14
Joined: Sat Apr 13, 2019 6:40 am

Re: package exe not work \\?\ path

Post by MIC-23145632 » Mon Apr 22, 2019 2:14 am

davidc wrote:
Fri Apr 19, 2019 6:39 am
Please update to the v162 service build. It will resolve the manifest issue as well as an encoding issue introduced in the v161 service build.

The v162 build also includes a manifest template you can access via the File->New menu. The template (Custom Packager Manifest) is located under the Other category.
I have updated to the latest version
[IMAGE REMOVED BY MODERATOR]

Then modify the XML file
Snipaste_2019-04-22_17-07-42.png
Snipaste_2019-04-22_17-07-42.png (42.39 KiB) Viewed 957 times
Snipaste_2019-04-22_17-09-45.png
Snipaste_2019-04-22_17-09-45.png (30.95 KiB) Viewed 957 times

MIC-23145632
Posts: 14
Joined: Sat Apr 13, 2019 6:40 am

Re: package exe not work \\?\ path

Post by MIC-23145632 » Mon Apr 22, 2019 2:17 am

Powershell execution is ok
Snipaste_2019-04-22_17-10-41.png
Snipaste_2019-04-22_17-10-41.png (43.23 KiB) Viewed 955 times
Execution is still wrong
Snipaste_2019-04-22_17-10-02.png
Snipaste_2019-04-22_17-10-02.png (37.14 KiB) Viewed 955 times
Snipaste_2019-04-22_17-15-16.png
Snipaste_2019-04-22_17-15-16.png (26.84 KiB) Viewed 955 times

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: package exe not work \\?\ path

Post by davidc » Mon Apr 22, 2019 8:05 am

Thank you for the update. I'm investigating the issue on my end and will post as soon as I have an update.
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: package exe not work \\?\ path

Post by davidc » Mon Apr 22, 2019 8:47 am

Turns out extended path support requires .NET 4.6.2 or higher. We will look into updating the .NET runtimes for the V5 hosts. They are currently using .NET 4.5.2.
David
SAPIEN Technologies, Inc.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: package exe not work \\?\ path

Post by davidc » Mon Apr 22, 2019 3:12 pm

Found a way to enable extended paths. Instead of using the manifest, add the following to the config file of your packager executable:

Code: Select all

    <runtime>
      <AppContextSwitchOverrides value="Switch.System.IO.BlockLongPaths=false;Switch.System.IO.UseLegacyPathHandling=false"/>
    </runtime>
   
Complete example:

Code: Select all

<?xml version="1.0" encoding="utf-8" ?> 
<configuration> 
    <startup useLegacyV2RuntimeActivationPolicy="true"> 
        <supportedRuntime version="v4.0" />    
	    <supportedRuntime version="v2.0" />
    </startup> 
	<runtime>
      <AppContextSwitchOverrides value="Switch.System.IO.BlockLongPaths=false;Switch.System.IO.UseLegacyPathHandling=false"/>
    </runtime>
</configuration>
David
SAPIEN Technologies, Inc.

MIC-23145632
Posts: 14
Joined: Sat Apr 13, 2019 6:40 am

Re: package exe not work \\?\ path

Post by MIC-23145632 » Mon Apr 22, 2019 6:34 pm

Hello, if you mean to modify the config file,look like this
Snipaste_2019-04-23_09-24-53.png
Snipaste_2019-04-23_09-24-53.png (18.17 KiB) Viewed 904 times

That problem will return to what I encountered at the beginning, and the package must be modified once.
viewtopic.php?f=12&t=13838#p73059
Snipaste_2019-04-23_09-30-48.png
Snipaste_2019-04-23_09-30-48.png (70.39 KiB) Viewed 904 times

If this is the last solution, then I found it at the beginning!
However , thank you so many times for your help.

User avatar
davidc
Posts: 5913
Joined: Thu Aug 18, 2011 4:56 am

Re: package exe not work \\?\ path

Post by davidc » Tue Apr 23, 2019 7:06 am

Sometimes our journeys go in a roundabout path and end where it all started :)
David
SAPIEN Technologies, Inc.